Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066050 - Default time zone update is not seen in UI
Summary: Default time zone update is not seen in UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Martin Betak
QA Contact: bugs@ovirt.org
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 14:59 UTC by Ilanit Stein
Modified: 2016-02-10 19:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:20:37 UTC
oVirt Team: Virt


Attachments (Terms of Use)

Description Ilanit Stein 2014-02-17 14:59:41 UTC
Description of problem:
After update of  DefaultWindowsTimeZone, and ovirt-engine service restart,
Looking in webadmin, for a new windows VM, the time zone is set to the orifinal default time zone, "greenwich standard time" and not the new one set. 

Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.7.beta2.el6.noarch

Steps to Reproduce:
1.engine-config -s DefaultWindowsTimeZone="Israel Standard Time"
2. service ovirt-engine restart

Expected results:
DefaultWindowsTimeZone should get updated for a new windows VM.

Comment 1 Ilanit Stein 2014-02-18 08:40:54 UTC
Same problem is seen for DefaultGeneralTimeZone:

[root@dhcp163-53 ~]# engine-config -s DefaultGeneralTimeZone='Europe/London'
[root@dhcp163-53 ~]# service ovirt-engine restart
Stopping oVirt Engine:                                     [  OK  ]
Starting oVirt Engine:                                     [  OK  ]

Create a new VM with "Other OS" has default time zone "(GMT) Greenwich Mean Time"

Comment 2 Itamar Heim 2014-02-23 08:28:27 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 3 Martin Betak 2014-03-19 15:25:25 UTC
I tried to reproduce this on latest 3.4 and as for the windows the timezone was updated correctly and shown in UI.

The general case with Europe/London is actually correct because Britain uses GMT+0 and we map the Key 'Europe/London' to the same display value as the 'GMT Standard Time'. Please try changing to some non-zero offset time zones such as 'Asia/Jerusalem'

Comment 4 Ilanit Stein 2014-04-07 09:15:51 UTC
I checked in av6 (latest rhevm). Both windows & general default params work fine.
I assume there was some change, that fixed that, which I am not ware of.
The bug indeed existed in ovirt-engine-3.4.0-0.7.beta2, 
and as it is OK now on latest rhevm, I am moving it to Verified.

Comment 5 Sandro Bonazzola 2014-10-17 12:20:37 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.