Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066041 - Domain mode cluster - jpp-branding-extension.ear is not load in the second server
Summary: Domain mode cluster - jpp-branding-extension.ear is not load in the second se...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Lucas Ponce
QA Contact: Tomas Kyjovsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 14:49 UTC by mgottval
Modified: 2014-09-15 00:06 UTC (History)
2 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-17 15:30:17 UTC
Type: Bug


Attachments (Terms of Use)
layout with default profile (deleted)
2014-02-17 15:34 UTC, Tomas Kyjovsky
no flags Details
layout with ha profile (deleted)
2014-02-17 15:34 UTC, Tomas Kyjovsky
no flags Details

Description mgottval 2014-02-17 14:49:20 UTC
Description of problem:
Second server can not load jpp-branding-extension.ear when running 2-node cluster in domain mode.

Steps to Reproduce:
1. In domain.xml uncomment "profile-ha-group", in "host.xml" change profiles of both servers to "profile-ha-group"
2. Run the h2 database for clustering: java -cp modules/system/layers/base/com/h2database/h2/main/h2-1.3.168-redhat-2.jar org.h2.tools.Server
3. in jboss-portal-6.1/bin run demo-domain-setup.sh
4. run domain.sh

The jpp-branding-extension.ear from gatein/extensions must be added to the domain/servers/server-two/extensions to be loaded. In another case, the layout of the second server is broken.

Comment 2 Lucas Ponce 2014-02-17 15:30:17 UTC
Hi,

This is a expected behaviour:

- server-one has not explicit "gatein.extensions.dir" so, it will take JBOSS_HOME/gatein/extensions as default one [1]

- server-two has explicit "gatein.extension.dir", where only there is a jpp-modile-integration.ear extension, so it's a expected behaviour not to found jpp-branding-extension.ear [2]

So, it doesn't seem a bug or broken functionality in this case.



[1] https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Portal/6.1/html-single/Administration_and_Configuration_Guide/index.html#chap-Configuring_JBoss_Portal_Domain_Mode

[2] Section 5.5 Domain Mode Quickstart of link [1]

Comment 3 Tomas Kyjovsky 2014-02-17 15:34:02 UTC
Created attachment 864135 [details]
layout with default profile

Comment 4 Tomas Kyjovsky 2014-02-17 15:34:31 UTC
Created attachment 864137 [details]
layout with ha profile

Comment 5 Tomas Kyjovsky 2014-02-17 15:34:53 UTC
It looks like this is issue is also present with the "default" profile however there is one apparent difference:

- with the "default" profile I can see the second server has gatein skin however layout is ok

- with the "ha" profile the second server also has the gatein skin but the layout is broken


Note You need to log in before you can comment on or make changes to this bug.