Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065979 - packstack man page does not contain any information regarding ML2 parameters
Summary: packstack man page does not contain any information regarding ML2 parameters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 4.0
Hardware: Unspecified
OS: Linux
high
medium
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Gaël Chamoulaud
QA Contact: Nir Magnezi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 12:48 UTC by Nir Magnezi
Modified: 2014-09-08 05:42 UTC (History)
7 users (show)

Fixed In Version: openstack-packstack-2014.1.1-0.16.dev1100.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-08 15:37:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0846 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement - Packstack 2014-07-08 19:23:14 UTC
OpenStack gerrit 93709 None None None Never

Description Nir Magnezi 2014-02-17 12:48:37 UTC
Description of problem:
=======================
packstack man page does not contain any information regarding ML2 parameters.
The following parameters should be documented in the man page:
# grep ML2 ANS_ML2_VXLAN
CONFIG_NEUTRON_ML2_TYPE_DRIVERS
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS
CONFIG_NEUTRON_ML2_FLAT_NETWORKS
CONFIG_NEUTRON_ML2_VLAN_RANGES
CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES
CONFIG_NEUTRON_ML2_VXLAN_GROUP
CONFIG_NEUTRON_ML2_VNI_RANGES

Version-Release number of selected component (if applicable):
=============================================================
openstack-packstack-2013.2.1-0.24.dev982.el6ost.noarch

How reproducible:
=================
Always.

Steps to Reproduce:
===================
man packstack

Actual results:
===============
As stated in the problem description.

Expected results:
=================
ML2 parameters information and usage.

Comment 2 Ofer Blaut 2014-06-05 06:08:59 UTC
tested 

CONFIG_NEUTRON_ML2_TYPE_DRIVERS
              A comma separated list of network type (eg: local, flat, vlan, gre, vxlan).

       CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES
              A comma separated ordered list of network_types to allocate as tenant networks (eg: local, flat, vlan, gre, vxlan). The value 'local' is only useful for single-box testing but provides no connectivity between hosts.

       CONFIG_NEUTRON_ML2_SM_DRIVERS
              A  comma  separated  ordered list of networking mechanism driver entrypoints to be loaded from the neutron.ml2.mechanism_drivers namespace (eg: logger, test, linuxbridge, openvswitch, hyperv, ncs, arista, cisco_nexus,
              l2population).

       CONFIG_NEUTRON_ML2_FLAT_NETWORKS
              A comma separated list of physical_network names with which flat networks can be created. Use * to allow flat networks with arbitrary physical_network names.

       CONFIG_NEUTRON_ML2_VLAN_RANGES
              A comma separated list of <physical_network>:<vlan_min>:<vlan_max> or <physical_network> specifying physical_network names usable for VLAN provider and tenant networks, as well as ranges of VLAN tags on each available
              for allocation to tenant networks.

       CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES
              A comma separated list of <tun_min>:<tun_max> tuples enumerating ranges of GRE tunnel IDs that are available for tenant network allocation. Should be an array with tun_max +1 - tun_min > 1000000.

       CONFIG_NEUTRON_ML2_VXLAN_GROUP
              Multicast  group  for  VXLAN. If unset, disables VXLAN enable sending allocate broadcast traffic to this multicast group. When left unconfigured, will disable multicast VXLAN mode. Should be an Multicast IP (v4 or v6)
              address.

       CONFIG_NEUTRON_ML2_VNI_RANGES
              A comma separated list of <vni_min>:<vni_max> tuples enumerating ranges of VXLAN VNI IDs that are available for tenant network allocation. Min value is 0 and Max value is 16777215.

Comment 5 errata-xmlrpc 2014-07-08 15:37:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0846.html


Note You need to log in before you can comment on or make changes to this bug.