Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065951 - contacts are shown several times in overview
Summary: contacts are shown several times in overview
Keywords:
Status: CLOSED DUPLICATE of bug 1030948
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 7.0
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 11:33 UTC by Vladimir Benes
Modified: 2014-03-06 18:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-06 18:35:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
duplicated contacts (deleted)
2014-02-17 11:35 UTC, Vladimir Benes
no flags Details

Description Vladimir Benes 2014-02-17 11:33:37 UTC
Description of problem:
not sure if this is online-accounts, contacts or shell's issue so I am filing this to G-S first. Please switch as appropriate.
I have no default address book set in contacts. I have added google online accounts with two auth verification and suddenly I see this contact duplicity all over. 

Version-Release number of selected component (if applicable):
gnome-online-accounts-3.8.5-6.el7.x86_64
gnome-shell-3.8.4-22.el7.x86_64
gnome-contacts-3.8.2-5.el7.x86_64
tracker-0.16.2-7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.add google account with some contacts (I added my android phone one)
2.search for your phone contacts

Actual results:
all contacts seem to be duplicated several times.

Expected results:
every contact shown just once.

Additional info:

Comment 1 Vladimir Benes 2014-02-17 11:35:54 UTC
Created attachment 864064 [details]
duplicated contacts

Comment 2 Florian Müllner 2014-02-19 12:01:56 UTC
(In reply to Vladimir Benes from comment #0)
> Actual results:
> all contacts seem to be duplicated several times.

Not only contacts, the Settings result for "Online Accounts" also shows up multiple times. This is definitively a gnome-shell issue.

Comment 4 Florian Müllner 2014-03-06 18:35:56 UTC
This should be fixed as side effect alongside the crasher in bug 1030948, marking as such.

*** This bug has been marked as a duplicate of bug 1030948 ***


Note You need to log in before you can comment on or make changes to this bug.