Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065935 - There are JBAS014613 and java.lang.OutOfMemory Errors in server.log for jbosseap sfsbTest
Summary: There are JBAS014613 and java.lang.OutOfMemory Errors in server.log for jboss...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 10:48 UTC by Anping Li
Modified: 2015-05-15 00:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 19:49:27 UTC


Attachments (Terms of Use)
Jbosseap server log file for this defect (deleted)
2014-02-17 10:51 UTC, Anping Li
no flags Details

Description Anping Li 2014-02-17 10:48:37 UTC
Description of problem:
Jbosseap cartridge with sample application sfsbTest doesn't work.  The sfsbTest page can't be accessed. and there are "JBAS014613: Operation ("read-resource") failed - address"  and 'java.lang.OutOfMemory errors' in jbosseap/logs/server.log. 

Version-Release number of selected component (if applicable):
devenv_4382

How reproducible:
Allways 

Steps to Reproduce:
1.rhc app create jboss1 jbosseap -s
2.Clone and build a sample application sfsbTest
   git clone git://github.com/bdecoste/sfsbTest.git
   cd sfsbTest
   mvn clean package
3.cp sfsbTest/target/sfsbTest-1.0.war jbosseap/deployments/
4. git push to deployment sfsbTest
5. ssh app and check jbosseap/logs/server.log.

Actual results:
There some JBAS014613 and java.lang.out of memory message in server.log as below
2014/02/17 01:46:24,653 ERROR [org.jboss.as.controller.management-operation] (management-handler-thread - 4) JBAS014613: Operation ("read-resource") failed - address: ([("subsystem" => "deployment-scanner")]) - failure description: "JBAS014807: Management resource '[(\"subsystem\" => \"deployment-scanner\")]' not found"
No error is reported.
2014/02/17 05:00:43,651 ERROR [org.hornetq.core.client] (Thread-1 (HornetQ-remoting-threads-HornetQServerImpl::serverUUID=284d0559-979e-11e3-9d9e-bf95e918e09d-28059738-26033134)) HQ214017: Caught unexpected Throwable: java.lang.OutOfMemoryError: unable to create new native thread
        at java.lang.Thread.start0(Native Method) [rt.jar:1.7.0_51]
        at java.lang.Thread.start(Thread.java:713) [rt.jar:1.7.0_51]
        at java.util.concurrent.ThreadPoolExecutor.addWorker(ThreadPoolExecutor.java:949) [rt.jar:1.7.0_51]
        at java.util.concurrent.ThreadPoolExecutor.execute(ThreadPoolExecutor.java:1360) [rt.jar:1.7.0_51]
        at org.hornetq.utils.OrderedExecutorFactory$OrderedExecutor.execute(OrderedExecutorFactory.java:136) [hornetq-core-client.jar:2.3.14.Final-redhat-1]
        at org.hornetq.core.protocol.core.impl.RemotingConnectionImpl.bufferReceived(RemotingConnectionImpl.java:496) [hornetq-core-client.jar:2.3.14.Final-redhat-1]
        at org.hornetq.core.remoting.server.impl.RemotingServiceImpl$DelegatingBufferHandler.bufferReceived(RemotingServiceImpl.java:564) [hornetq-server.jar:2.3.14.Final-redhat-1]
        at org.hornetq.core.remoting.impl.invm.InVMConnection$1.run(InVMConnection.java:160) [hornetq-server.jar:2.3.14.Final-redhat-1]
        at org.hornetq.utils.OrderedExecutorFactory$OrderedExecutor$1.run(OrderedExecutorFactory.java:107) [hornetq-core-client.jar:2.3.14.Final-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]

Expected results:
No error message

Additional info:
The server log is attached.

Comment 1 Anping Li 2014-02-17 10:51:07 UTC
Created attachment 864055 [details]
Jbosseap server log file for this defect

Comment 2 Michal Fojtik 2014-02-17 12:32:13 UTC
Is it possible to tweak JAVA_OPTS and add more memory to JBoss process? 
Also is this regression or something new?

Comment 3 Jakub Hadvig 2014-02-17 14:05:35 UTC
Tried to reproduce this issue on devenv_4383, but after reproduction the application is accesible. Also when I look at the server.log file I get different error, which I dont thing should cause any error but anyway the app. is accesible. 

OUTPUT:

2014/02/17 08:19:18,093 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC000001: Failed to start service jboss.deployment.unit."sfsbTest-1.0.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."sfsbTest-1.0.war".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment "sfsbTest-1.0.war"
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server.jar:7.3.1.Final-redhat-3]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc.jar:1.0.4.GA-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc.jar:1.0.4.GA-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]
Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011047: Component class org.jboss.jndiTest.EntityTesterBean for component EntityTesterBean has errors:
JBAS011440: Can't find a persistence unit named jpa-test in deployment "sfsbTest-1.0.war"
        at org.jboss.as.ee.component.deployers.ModuleJndiBindingProcessor$1.handle(ModuleJndiBindingProcessor.java:171)
        at org.jboss.as.ee.component.ClassDescriptionTraversal.run(ClassDescriptionTraversal.java:54)
        at org.jboss.as.ee.component.deployers.ModuleJndiBindingProcessor.processClassConfigurations(ModuleJndiBindingProcessor.java:164)
        at org.jboss.as.ee.component.deployers.ModuleJndiBindingProcessor.deploy(ModuleJndiBindingProcessor.java:157)
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server.jar:7.3.1.Final-redhat-3]
        ... 5 more

Comment 4 Ben Parees 2014-02-17 14:29:22 UTC
The original error is a thread limit exception and not an actual memory limitation:
https://stackoverflow.com/questions/16789288/java-lang-outofmemoryerror-unable-to-create-new-native-thread

So presumably it hit the 250 thread/process limit in the gear.

I will attempt the scenario and see what failure I reproduce.

Comment 5 Ben Parees 2014-02-17 21:12:32 UTC
I am seeing the same issue as in comment 3.  It appears the recreate steps are missing some configuration information.  I see the application includes a standalone.xml but the recreate steps do not mention using it.  Is there some config in the standalone.xml that needs to be put into the application's standalone.xml?

That said, this seems like an application issue with the application/test resulting in too many threads being created, so I would suggest looking at it from that perspective.

Comment 6 Anping Li 2014-02-18 03:20:06 UTC
According to previous steps ,nothing need to put into applcations standalone.xml. And the sfsbTest-1.0/index.html can't be viewed.

Comment 7 Ben Parees 2014-02-18 03:30:44 UTC
index.html can't be viewed because the war fails to deploy because it is not properly configured (references a non-existent jpa-test persistence unit).

So there is some missing configuration here.  If your test does not actually require the "EntityTesterBean" then perhaps you can try removing it from the war, as that will eliminate this error which is preventing deployment.

Otherwise, you need to provide the configuration for the jpa-test persistence unit that is being referenced.

Please let me know if that makes sense.

Comment 8 Anping Li 2014-02-18 11:44:01 UTC
After remove 'EntityTesterBean',the deployment succeed. and sfsbTest/index.html can be access. so the JBAS014613 and java.lang.OutOfMemory Errors are caused by miss configuration.
One thing in my mind,it fails to deploy sfsbTest, but no error code is return to client side. could we catch the error and return to client side?

Comment 9 Ben Parees 2014-02-18 18:09:58 UTC
Unfortunately while it is not started successfully, it is considered deployed by jboss so our logic does not flag it.  If you open an RFE we can look into whether more can be done to detect/flag this scenario in the future.


Note You need to log in before you can comment on or make changes to this bug.