Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065932 - [QE] (6.3.0) JBWEB003012 Socket accept failed Error message while stopping the domain on HP-UX
Summary: [QE] (6.3.0) JBWEB003012 Socket accept failed Error message while stopping th...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER1
: EAP 6.3.0
Assignee: Rémy Maucherat
QA Contact: Radim Hatlapatka
Russell Dickenson
URL:
Whiteboard:
: 1073396 (view as bug list)
Depends On:
Blocks: eap63-beta-blockers 1072345
TreeView+ depends on / blocked
 
Reported: 2014-02-17 10:08 UTC by Petr Kremensky
Modified: 2014-06-28 15:41 UTC (History)
7 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1072345 (view as bug list)
Environment:
Last Closed: 2014-06-28 15:41:32 UTC
Type: Bug


Attachments (Terms of Use)
Multiple domain starting script (deleted)
2014-02-17 10:08 UTC, Petr Kremensky
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1073396 None None None Never

Internal Links: 1073396

Description Petr Kremensky 2014-02-17 10:08:14 UTC
Created attachment 864049 [details]
Multiple domain starting script

Description of problem:
From time to time I get the following Error messages while stopping the domain on HP-UX v11.3

uname -a
HP-UX eph-01 B.11.31 U ia64 3411070677
I am using 64b hp-ux jdk 1.7
java -d64 -version

Version-Release number of selected component (if applicable):
EAP 6.3.0.DR0

Steps to Reproduce:
1. unzip -q jboss-eap-6.3.0.DR0.zip
2. cd jboss-eap-6.3/bin
3. Add "-d64" switch to java_opts
echo JAVA_OPTS=\"-d64 \$JAVA_OPTS\" >> domain.conf
4. run test.sh from attachment which will start domain several times and ends once Error is found in logs.

Actu{"outcome" => "success"}
03:34:22,338 INFO  [org.jboss.as.process] (Thread-14) JBAS012016: Shutting down process controller
03:34:22,339 INFO  [org.jboss.as.process.Host Controller.status] (Thread-14) JBAS012018: Stopping process 'Host Controller'
[Host Controller] 03:34:22,355 INFO  [org.jboss.as.host.controller] (Host Controller Service Threads - 32) JBAS010923: Stopping server server-two
[Host Controller] 03:34:22,356 INFO  [org.jboss.as.host.controller] (Host Controller Service Threads - 32) JBAS010923: Stopping server server-one
03:34:22,407 INFO  [org.jboss.as.process.Server:server-two.status] (ProcessController-threads - 3) JBAS012018: Stopping process 'Server:server-two'
03:34:22,408 INFO  [org.jboss.as.process.Server:server-one.status] (ProcessController-threads - 3) JBAS012018: Stopping process 'Server:server-one'
[Server:server-one] 03:34:22,443 INFO  [org.apache.coyote.http11] (MSC service thread 1-15) JBWEB003075: Coyote HTTP/1.1 pausing on: http-localhost.fra.redhat.com/127.0.0.1:8080
[Server:server-one] 03:34:22,444 INFO  [org.apache.coyote.http11] (MSC service thread 1-15) JBWEB003077: Coyote HTTP/1.1 stopping on : http-localhost.fra.redhat.com/127.0.0.1:8080
[Server:server-one] 03:34:22,443 ERROR [org.apache.tomcat.util] (http-/127.0.0.1:8080-Acceptor-0) JBWEB003012: Socket accept failed: java.net.SocketException: Resource temporarily unavailable (errno:11)
[Server:server-one]         at java.net.PlainSocketImpl.socketAccept(Native Method) [rt.jar:1.7.0.08]
[Server:server-one]         at java.net.AbstractPlainSocketImpl.accept(AbstractPlainSocketImpl.java:398) [rt.jar:1.7.0.08]
[Server:server-one]         at java.net.ServerSocket.implAccept(ServerSocket.java:536) [rt.jar:1.7.0.08]
[Server:server-one]         at java.net.ServerSocket.accept(ServerSocket.java:504) [rt.jar:1.7.0.08]
[Server:server-one]         at org.apache.tomcat.util.net.DefaultServerSocketFactory.acceptSocket(DefaultServerSocketFactory.java:61) [jbossweb-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
[Server:server-one]         at org.apache.tomcat.util.net.JIoEndpoint$Acceptor.run(JIoEndpoint.java:309) [jbossweb-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
[Server:server-one]         at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0.08]
[Server:server-one] 
[Server:server-two] 03:34:22,443 INFO  [org.apache.coyote.http11] (MSC service thread 1-8) JBWEB003075: Coyote HTTP/1.1 pausing on: http-localhost.mad.redhat.com/127.0.0.1:8230
[Server:server-two] 03:34:22,442 ERROR [org.apache.tomcat.util] (http-/127.0.0.1:8230-Acceptor-0) JBWEB003012: Socket accept failed: java.net.SocketException: Resource temporarily unavailable (errno:11)
[Server:server-two]         at java.net.PlainSocketImpl.socketAccept(Native Method) [rt.jar:1.7.0.08]
[Server:server-two]         at java.net.AbstractPlainSocketImpl.accept(AbstractPlainSocketImpl.java:398) [rt.jar:1.7.0.08]
[Server:server-two]         at java.net.ServerSocket.implAccept(ServerSocket.java:536) [rt.jar:1.7.0.08]
[Server:server-two]         at java.net.ServerSocket.accept(ServerSocket.java:504) [rt.jar:1.7.0.08]
[Server:server-two]         at org.apache.tomcat.util.net.DefaultServerSocketFactory.acceptSocket(DefaultServerSocketFactory.java:61) [jbossweb-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
[Server:server-two]         at org.apache.tomcat.util.net.JIoEndpoint$Acceptor.run(JIoEndpoint.java:309) [jbossweb-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
[Server:server-two]         at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0.08]
[Server:server-two] 
[Server:server-two] 03:34:22,444 INFO  [org.apache.coyote.http11] (MSC service thread 1-8) JBWEB003077: Coyote HTTP/1.1 stopping on : http-localhost.mad.redhat.com/127.0.0.1:8230
[Server:server-two] 03:34:22,445 INFO  [org.jboss.as.connector.deployment] (MSC service thread 1-14) JBAS010410: Unbound JCA ConnectionFactory [java:/JmsXA]
[Server:server-two] 03:34:22,448 INFO  [org.apache.catalina.core] (MSC service thread 1-14) JBWEB001079: Container org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/] has not been started
[Server:server-two] 03:34:22,448 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-28) JBAS010409: Unbound data source [java:jboss/datasources/ExampleDS]
[Server:server-one] 03:34:22,448 INFO  [org.jboss.as.connector.deployment] (MSC service thread 1-28) JBAS010410: Unbound JCA ConnectionFactory [java:/JmsXA]
[Server:server-two] 03:34:22,448 INFO  [org.jboss.jaxr] (MSC service thread 1-30) JBAS014002: UnBinding JAXR ConnectionFactory: java:jboss/jaxr/ConnectionFactory
[Server:server-one] 03:34:22,449 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-12) JBAS010409: Unbound data source [java:jboss/datasources/ExampleDS]
[Server:server-one] 03:34:22,450 INFO  [org.apache.catalina.core] (MSC service thread 1-5) JBWEB001079: Container org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/] has not been started
[Server:server-two] 03:34:22,451 INFO  [org.jboss.as.messaging] (ServerService Thread Pool -- 25) JBAS011605: Unbound messaging object to jndi name java:jboss/exported/jms/RemoteConnectionFactory
[Server:server-one] 03:34:22,452 INFO  [org.jboss.jaxr] (MSC service thread 1-4) JBAS014002: UnBinding JAXR ConnectionFactory: java:jboss/jaxr/ConnectionFactory
[Server:server-one] 03:34:22,456 INFO  [org.jboss.as.messaging] (ServerService Thread Pool -- 25) JBAS011605: Unbound messaging object to jndi name java:jboss/exported/jms/RemoteConnectionFactory
[Server:server-one] 03:34:22,478 INFO  [org.hornetq.ra] (ServerService Thread Pool -- 23) HQ151003: HornetQ resource adaptor stopped
[Server:server-two] 03:34:22,477 INFO  [org.hornetq.ra] (ServerService Thread Pool -- 16) HQ151003: HornetQ resource adaptor stopped
[Server:server-one] 03:34:22,498 INFO  [org.hornetq.core.server] (ServerService Thread Pool -- 23) HQ221002: HornetQ Server version 2.3.14.Final (2.3.14, 123) [3e07d05b-97ae-11e3-9995-9bac29a66ab3] stopped
[Server:server-two] 03:34:22,498 INFO  [org.hornetq.core.server] (ServerService Thread Pool -- 16) HQ221002: HornetQ Server version 2.3.14.Final (2.3.14, 123) [401a5cab-97ae-11e3-b696-c5c8a8eee4f8] stopped
[Host Controller] 03:34:22,505 INFO  [org.jboss.as.host.controller] (Remoting "eap-perf-hpux-01.mw.lab.eng.bos.redhat.com:MANAGEMENT" task-3) JBAS010926: Unregistering server server-one
[Host Controller] 03:34:22,506 INFO  [org.jboss.as.host.controller] (Remoting "eap-perf-hpux-01.mw.lab.eng.bos.redhat.com:MANAGEMENT" task-4) JBAS010926: Unregistering server server-two
[Server:server-one] 03:34:22,516 INFO  [org.jboss.as] (MSC service thread 1-19) JBAS015950: JBoss EAP 6.3.0.Alpha1 (AS 7.4.0.Final-redhat-0) stopped in 80ms
[Server:server-two] 03:34:22,517 INFO  [org.jboss.as] (MSC service thread 1-2) JBAS015950: JBoss EAP 6.3.0.Alpha1 (AS 7.4.0.Final-redhat-0) stopped in 83ms
[Server:server-one] 
[Server:server-two] 
03:34:22,561 INFO  [org.jboss.as.process.Server:server-one.status] (reaper for Server:server-one) JBAS012010: Process 'Server:server-one' finished with an exit status of 0
03:34:22,564 INFO  [org.jboss.as.process.Server:server-two.status] (reaper for Server:server-two) JBAS012010: Process 'Server:server-two' finished with an exit status of 0
[Host Controller] 03:34:22,627 INFO  [org.jboss.as.host.controller] (ProcessControllerConnection-thread - 2) JBAS010926: Unregistering server server-one
[Host Controller] 03:34:22,629 INFO  [org.jboss.as.host.controller] (ProcessControllerConnection-thread - 2) JBAS010926: Unregistering server server-two
[Host Controller] 03:34:22,767 INFO  [org.jboss.as] (MSC service thread 1-27) JBAS015950: JBoss EAP 6.3.0.Alpha1 (AS 7.4.0.Final-redhat-0) stopped in 421ms
03:34:22,790 INFO  [org.jboss.as.process.Host Controller.status] (reaper for Host Controller) JBAS012010: Process 'Host Controller' finished with an exit status of 0
03:34:22,791 INFO  [org.jboss.as.process] (Thread-14) JBAS012015: All processes finished; exitingal results:


Expected results:
 No Error message in logs.

Additional info:
 This is quite blocker for my testing as tests are failing because of the error message in logs while stopping the server.

Comment 1 Rostislav Svoboda 2014-03-05 12:51:11 UTC
Proposing as blocker as discussed on EAP 6 PM meeting March 4.

This is blocking acceptance tests where we have requirement for error-less startup & shutdown.

Comment 2 John Doyle 2014-03-06 21:37:30 UTC
I don't consider this a blocker from a customer perspective for Alpha, but what's the effect on our testing?  How much testing is not getting executed because of this?

Comment 3 Petr Kremensky 2014-03-07 15:04:51 UTC
We could evaluate impact on testing at the end of DR3 cycle. 

As far as I could say all server start-up tests, and script tests are interfered by this on HP-UX.

Comment 4 Jean-frederic Clere 2014-03-12 17:14:39 UTC
fixed by jbossweb r2382 (now it is a debug message, which makes more sense).

Comment 5 Jean-frederic Clere 2014-03-12 17:21:13 UTC
*** Bug 1073396 has been marked as a duplicate of this bug. ***

Comment 6 Petr Kremensky 2014-04-09 06:01:04 UTC
Verified on EAP 6.3.0.ER1. I don't see the error anymore.

Comment 7 Scott Mumford 2014-05-14 00:54:54 UTC
Marking for exclusion from 6.3.0 Beta release notes as both 'affects' and 'fix' versions are listed as 6.3.0, suggesting this was not a customer-facing issue.


Note You need to log in before you can comment on or make changes to this bug.