Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065922 - BigApp: Task variables are not mapped correctly to humam task form fields
Summary: BigApp: Task variables are not mapped correctly to humam task form fields
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Babak Mozaffari
QA Contact: Jan Hrcek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 09:53 UTC by Jan Hrcek
Modified: 2014-02-17 16:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-17 16:34:38 UTC
Type: Bug


Attachments (Terms of Use)
Steps to reproduce - video (deleted)
2014-02-17 09:53 UTC, Jan Hrcek
no flags Details
server.log showing the exception (deleted)
2014-02-17 09:54 UTC, Jan Hrcek
no flags Details

Description Jan Hrcek 2014-02-17 09:53:38 UTC
Created attachment 864024 [details]
Steps to reproduce - video

Description of problem:
When executing the MortgageApplication process and filling in input for its respective human tasks in Task list perspective, the value of taskInputApplication/appraisal/value is not loaded in the form.

Observe steps to reproduce in the video attached.

The problem was introduced recently with BPMS 6.0.1, when the form modeler's subform feature was used to group task variables into domain entities (Application, Applicant, Appraisal etc.)

There must be some problem in the Process definition (some Process variable not mapped correctly to task variable) or in Form definition (Input/Output binding expression for the fiels is incorrect). Please review.

Version-Release number of selected component (if applicable):
BPMS 6.0.1 ER1

How reproducible:
Always

Steps to Reproduce:
Observe detailed steps to reproduce in the video

Note: in the video I use 1 user, who has all the roles necessary to execute the process (admin, manager, broker, appraiser)


Actual results:
When you get to human task 'Increase down payment' the value of 'Appraised value' field is not loaded from the process instance.

Expected results:
Process/task variables should be mapped to forms correctly and so for example 'Increase Down Payment' form should displaye value of 'Appraised value' field, value for which was set in the previous process tasks.

Comment 1 Jan Hrcek 2014-02-17 09:54:27 UTC
Created attachment 864026 [details]
server.log showing the exception

Comment 2 Kris Verlaenen 2014-02-17 14:31:34 UTC
Babak, do you have time to take a look at this?

Comment 3 Babak Mozaffari 2014-02-17 16:34:38 UTC
This is expected behavior. The property has not been appraised yet, but even with the stated selling price, the applicant does not qualify.

In other words, the Appraisal user task will have to be completed at some point, but has not yet, so appraisal value is still non-existent. If the down payment is revised up and the borrower qualifies, the next step will be to enter an appraisal value. If appraisal comes in at less than property price, the rules may determine that the down payment is (yet again) too low and request an increase but now there will be an appraisal value and it is displayed.


Note You need to log in before you can comment on or make changes to this bug.