Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065886 - Live storage migration fails when snapshot disk attached to other vm
Summary: Live storage migration fails when snapshot disk attached to other vm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Daniel Erez
QA Contact: Raz Tamir
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 08:45 UTC by Raz Tamir
Modified: 2016-02-10 16:35 UTC (History)
8 users (show)

Fixed In Version: v4.14.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:25:00 UTC
oVirt Team: Storage


Attachments (Terms of Use)
vdsm and engine logs (deleted)
2014-02-17 08:45 UTC, Raz Tamir
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 20029 None MERGED vm: pre-validate disks for snapshot Never
oVirt gerrit 24867 None MERGED vm: snapshot transient disk check should be per disk Never
oVirt gerrit 25006 None MERGED vm: pre-validate disks for snapshot Never
oVirt gerrit 25007 None MERGED vm: snapshot transient disk check should be per disk Never

Description Raz Tamir 2014-02-17 08:45:56 UTC
Created attachment 863986 [details]
vdsm and engine logs

Description of problem:
setup:
2 SD, 1 host, 2 vms with disks
1 vm with snapshot.
When attaching snapshot disk of first vm to second vm (backup api - http://www.ovirt.org/Features/Backup-Restore_API_Integration), and trying to migrate second vm disks, operation fails with message :
"Failed to complete snapshot 'Auto-generated for Live Storage Migration' creation for VM 'vm_1'."

The 'Auto-generated for Live Storage Migration' snapshot is still in snapshot list of the second vm and cannot be deleted.

From vdsm side: Thread-42492::DEBUG::2014-02-17 10:09:50,182::
BindingXMLRPC::977::vds::(wrapper)
return vmSnapshot with {'status': {'message': 'Action not permitted on a VM with transient disks', 'code': 59}}

Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.5.beta1.el6.noarch
vdsm-4.14.1-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Attach snapshot disk of first vm to second vm
2. Move second vm disk to other storage domain
3.

Actual results:
New snapshot 'Auto-generated for Live Storage Migration' is created and ERROR message appears: "Failed to complete snapshot 'Auto-generated for Live Storage Migration' creation for VM 'vm_1'." this snapshot isn't deleted after the error message

Expected results:
A message that alerts the user that this operation is invalid

Additional info:

Comment 1 Sandro Bonazzola 2014-03-31 12:25:00 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.