Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065881 - [origin_ui_424]Incorrect url of the redirect link "Node.js"," ZendServer", "DIY / Downloadable Cartridge" on new-application-gallery page. And no diy cartridge technologie page.
Summary: [origin_ui_424]Incorrect url of the redirect link "Node.js"," ZendServer", "D...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: David Morrison
QA Contact: libra bugs
URL:
Whiteboard:
: 1066526 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 08:09 UTC by XiuJuan Wang
Modified: 2015-05-15 01:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-12 03:07:38 UTC


Attachments (Terms of Use)

Description XiuJuan Wang 2014-02-17 08:09:15 UTC
Description of problem:
Incorrect url of the redirect link "Node.js"," ZendServer", "DIY / Downloadable Cartridge" on new-application-gallery page.

The urls of above links are not correct now, they are as following:
https://<server>/developers/zendserver
https://<server>/developers/node.js
https://<server>/developers/diy / downloadable cartridge
The correct urls for "Node.js" ,"ZendServer", "Downloadable Cartridge" should be as following:
https://<server>developers/zend,
https://<server>developers/node-js,
https://<server>/developers/download-cartridges,
Besides, there is no page for diy cartridge by now.

Version-Release number of selected component (if applicable):
devenv_4382

How reproducible:
always

Steps to Reproduce:
1.Sign in on community with account to be powered by user
2.Create one app with all technologies in "Technologies Used:" list
3.Go to new-application-gallery page to check the links in "Technologies Used:".

Actual results:
 Click "Node.js"," ZendServer", "DIY / Downloadable Cartridge" will redirect to incorrect url page.

Expected results:
Sould redirect to correct technologies page.
https://<server>developers/zend,
https://<server>developers/node-js,
https://<server>/developers/download-cartridges,
https://<server>/developers/diy.


Additional info:

Comment 1 Jordan Liggitt 2014-02-17 14:35:48 UTC
Should use the keyword, not the lowercased display name

Comment 2 XiuJuan Wang 2014-02-18 07:39:56 UTC
Test on devenv_stage_700 and devenv_4389.
Zendserver and Node.js link can redirect to right url,
https://<server>/developers/zend,
https://<server>/developers/node-js.

But for "DIY / Downloadable Cartridge" link will redirect to
https://<server>/developers/custom. The page will show "Page not found
The page you requested may no longer exist". This is not correct.

For "Jenkins" link will go to http://<server>/jenkins/?, show 400 error,"Bad Request". This link works well on devenv_4382 yesterday.

Comment 3 David Morrison 2014-02-18 15:15:20 UTC
https://github.com/openshift/li/pull/2384

Comment 4 Jordan Liggitt 2014-02-18 15:30:50 UTC
On devenvs, /jenkins proxies to a Jenkins server

In production, /jenkins redirects to /developers/jenkins

There is an incorrect redirect from /developers/jenkins to /jenkins in the devenv. This has been removed from production and will be updated during the next devenv db dump.

Comment 5 Yujie Zhang 2014-02-19 02:10:34 UTC
*** Bug 1066526 has been marked as a duplicate of this bug. ***

Comment 6 XiuJuan Wang 2014-02-19 03:57:14 UTC
On PROD
https://www.openshift.com/jenkins will redirect to  /developers/jenkins page, which works correctly.
https://www.openshift.com/developers/custom  will redirect to  /developers/download-cartridges, works well.

On STG(devenv_stage_702)
https://www.stg.openshift.com/jenkins work correctly.
https://www.stg.openshift.com/developers/cutsom will not jump anywhere.And stay "Page not found."

On devenv_stage_702
http://<server>/jenkins/?,400 error.
https://<server>/developers/custom, stay "Page not found."

According to the comment 5,will move this bug to verified.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.