Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065874 - [QE] (6.2.x) NPE when using preserve, override without parameter
Summary: [QE] (6.2.x) NPE when using preserve, override without parameter
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Patching
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: CR2
: EAP 6.2.3
Assignee: Ivo Studensky
QA Contact: Jan Martiska
Russell Dickenson
URL:
Whiteboard:
: 1100935 (view as bug list)
Depends On: 1032041 1065536
Blocks: eap62-cp03-blockers
TreeView+ depends on / blocked
 
Reported: 2014-02-17 07:46 UTC by Petr Kremensky
Modified: 2018-12-06 15:53 UTC (History)
13 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-09 12:47:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Kremensky 2014-02-17 07:46:15 UTC
Clone of BZ1065536 for CP release.

Description of problem:
When attempting to apply the 6.2.1 patch to EAP 6.2.0 that was installed via the jboss-eap-6.2.0-installer.jar, an NPE occurs.

Version-Release number of selected component (if applicable):
6.2.0

How reproducible:
Always

Steps to Reproduce:
Install EAP 6.2.0 via the installer.  My config file for that is attached.
java -jar $PATH_TO/jboss-eap-6.2.0-installer.jar $PATH_TO/InstallConfig.xml

Then apply the patch for 6.2.1:

[standalone@localhost:9999 /] patch apply /home/rlucente/NotBackedUp/jboss-eap-6.2.1.zip
Conflicts detected: bin/jconsole.bat
Use the --override or --preserve arguments in order to resolve the conflict.

[standalone@localhost:9999 /] patch apply --override /home/rlucente/NotBackedUp/jboss-eap-6.2.1.zip
java.lang.NullPointerException
	at org.jboss.as.patching.cli.PatchHandler.createPatchOperationBuilder(PatchHandler.java:347)
	at org.jboss.as.patching.cli.PatchHandler.doHandle(PatchHandler.java:246)
	at org.jboss.as.cli.handlers.CommandHandlerWithHelp.handle(CommandHandlerWithHelp.java:86)
	at org.jboss.as.cli.impl.CommandContextImpl.handle(CommandContextImpl.java:600)
	at org.jboss.as.cli.impl.CommandContextImpl.handleSafe(CommandContextImpl.java:616)
	at org.jboss.as.cli.impl.CommandContextImpl.interact(CommandContextImpl.java:1204)
	at org.jboss.as.cli.impl.CliLauncher.main(CliLauncher.java:263)
	at org.jboss.as.cli.CommandLineMain.main(CommandLineMain.java:34)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.modules.Module.run(Module.java:292)
	at org.jboss.modules.Main.main(Main.java:455)

Actual results:
Both the --override and --preserve options result in an NPE

Expected results:
patch should be successfully applied

Additional info:
Installer adds only platform specific files (eg. no batch scripts are installed to linux hosts), also installation of some components is optional (appclient, xml schemas).

Comment 1 Emanuel Muckenhuber 2014-02-17 10:20:14 UTC
The NPE should be fixed in CP1, this is because the --override and --preserve arguments require a list of files. In case you don't want to override specific files, you can just use --override-all. I will fix the text to make this more clear.

Comment 2 Alexey Loubyansky 2014-02-24 11:49:21 UTC
This is the WFLY issue fixing the NPE https://issues.jboss.org/browse/WFLY-2536 and the original bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1032041

Comment 4 Emanuel Muckenhuber 2014-02-27 10:50:04 UTC
This has been merged into 6.x: https://github.com/jbossas/jboss-eap/pull/965

Comment 5 Ivo Studensky 2014-04-14 08:08:23 UTC
EAP 6.2.3 PR:

https://github.com/jbossas/jboss-eap/pull/1235

Comment 6 Jan Martiska 2014-05-07 13:11:35 UTC
Verified in EAP 6.2.3.CR2.

Comment 7 Petr Kremensky 2014-05-26 05:55:59 UTC
*** Bug 1100935 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.