Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065848 - The hypervisor will jump to login screen directly after press "Ctrl + C" key.
Summary: The hypervisor will jump to login screen directly after press "Ctrl + C" key.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-02-17 06:23 UTC by cshao
Modified: 2016-02-10 20:10 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:53:07 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 28021 master MERGED Catch CTRL+C and don't exit Never

Description cshao 2014-02-17 06:23:15 UTC
Description of problem:
The hypervisor will jump to login screen directly after press "Ctrl + C" key. "Ctrl + C" key for forced interrupt execution but not logout, so this is not a good behaviour. 

Note: No such issue with RHEV-H 6.4-20131016.0.el6 build. so it is a regression bug and set priority to high.

Version-Release number of selected component (if applicable):
rhevh-6.5-20140212.0

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh-6.5-20140212.0.
2. Enter TUI and press "Ctrl + C" key.
3.

Actual results:
1. The hypervisor will jump to login screen directly after press "Ctrl + C" key 

Expected results:
Press "Ctrl + C" key should not lead to logout hypervisor.

Additional info:

Comment 2 Fabian Deutsch 2014-04-10 15:13:47 UTC
I think I've seen a patch for this.

Comment 4 Fabian Deutsch 2014-07-24 16:03:02 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 6 cshao 2014-12-18 07:36:22 UTC
Test version:
rhev-hypervisor7-7.0-20141212.0.iso
ovirt-node-3.1.0-0.34.20141210git0c9c493.el7.noarch

rhev-hypervisor6-6.6-20141212.0.iso
ovirt-node-3.1.0-0.34.20141210git0c9c493.el6.noarch

Test steps:
1. Install rhevh
2. Enter TUI and press "Ctrl + C" key.

Test result:
Press "Ctrl + C" key will not lead to logout hypervisor.

So the bug is fixed with above build now, change bug status to VERIFIED.

Comment 8 errata-xmlrpc 2015-02-11 20:53:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.