Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065831 - CPU name and CPU Type are exchanged between RHEVH and RHEVM
Summary: CPU name and CPU Type are exchanged between RHEVH and RHEVM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1
Blocks: 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-02-17 05:18 UTC by Guohua Ouyang
Modified: 2016-02-10 20:10 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:53:01 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
rhevm35 no cpu more info (deleted)
2014-10-14 06:44 UTC, Ying Cui
no flags Details
rhevh6635_cpuinfo (deleted)
2014-10-14 06:45 UTC, Ying Cui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 29935 master MERGED system: Make CPU feature detection independent Never

Description Guohua Ouyang 2014-02-17 05:18:39 UTC
Created attachment 863948 [details]
cpu difference

Description of problem:
CPU name and CPU Type are exchanged between RHEVH and RHEVM.
on RHEVH, it's
CPU Name:  Intel(R) Xeon(R) CPU      E5606 @ 2.13GHz
CPU Type: Intel Westmere

on RHEVM, it's
CPU Name:  Intel Westmere Family
CPU Type: Intel(R) Xeon(R) CPU      E5606 @ 2.13GHz

Version-Release number of selected component (if applicable):
rhevh-6.5-20140212.1.el6ev

How reproducible:
100%


Steps to Reproduce:
1. Install rhevh
2. Register rhevh to rhevm
3. check cpu name and cpu type on RHEVH CPU details.
4. check host general info on RHEVM.

Actual results:
1. on RHEVH, it's
CPU Name:  Intel(R) Xeon(R) CPU      E5606 @ 2.13GHz
CPU Type: Intel Westmere

2. on RHEVM, it's
CPU Name:  Intel Westmere Family
CPU Type: Intel(R) Xeon(R) CPU      E5606 @ 2.13GHz

Expected results:
the results on RHEVH and RHEVM are consistent.

Additional info:

Comment 2 Fabian Deutsch 2014-04-10 15:15:04 UTC
RHEV-H is using libvirt to determin the CPU informations, but libvirt only provides the best known CPU from a list of known CPUs. This guessing can sometimes be incorrect.

Comment 3 Einav Cohen 2014-05-19 18:08:23 UTC
removing the UserExperience keyword (no user experience design advice is needed here - this is just a bug of non-matching lables-to-values)

Comment 4 Fabian Deutsch 2014-07-11 10:23:14 UTC
The attached patch will not show the CPU Family anymore on the Node side, because the CPU itself does not provide a textual representation of the Family.

To prevent inaccuracies the Family is dropped and only displayed on the RHEV-M side.

Comment 5 Fabian Deutsch 2014-07-24 16:03:14 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 7 Ying Cui 2014-10-14 06:09:41 UTC
Verified this bug on rhev-hypervisor6-6.6-20141008.0.iso and ovirt-node-3.1.0-0.22.20141010git96b7ca3.el6
rhevm 3.5.0-0.14.beta.el6ev
vdsm-4.16.6-1.el6ev.x86_64

In RHEVM 3.5 administrator portal, there is no CPU more info like RHEVM 3.4.z, the logical cpu core is correct on host and rhevm display.
and in RHEVH side, the cpu details display some fields from lscpu output.

So this bug is fixed.

Comment 8 Ying Cui 2014-10-14 06:44:54 UTC
Created attachment 946696 [details]
rhevm35 no cpu more info

Comment 9 Ying Cui 2014-10-14 06:45:25 UTC
Created attachment 946697 [details]
rhevh6635_cpuinfo

Comment 11 errata-xmlrpc 2015-02-11 20:53:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.