Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065778 - String in editor and search&replace don't match
Summary: String in editor and search&replace don't match
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 3.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: David Mason
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-16 21:57 UTC by Hedda Peters
Modified: 2015-07-31 01:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-31 01:49:39 UTC


Attachments (Terms of Use)

Description Hedda Peters 2014-02-16 21:57:14 UTC
Description of problem:
I found strings that appear to contain an extra character when looking at them in the search & replace view. When checking these strings out in the normal editor view, this extra character is not there. 

How reproducible:
?

Steps to Reproduce:
1. in the search and replace view, search for ">-" 
2. compare found string to same string in editor view

Actual results:
String shows an extra character in the search & replace results

Expected results:
Strings should be exactly the same

Additional info:
Link to project and screenshots to follow.

Comment 4 Hedda Peters 2014-02-16 22:06:28 UTC
Sounds like a small little bug, but it could lead to wrong "replace" operations, tag errors, and a translated document that won't build because of them.

Comment 5 David Mason 2014-02-17 00:28:21 UTC
(In reply to Hedda Peters from comment #4)
> Sounds like a small little bug, but it could lead to wrong "replace"
> operations, tag errors, and a translated document that won't build because
> of them.

It looks like this may be purely a display issue, so I would be surprised if it causes tag errors or build failures. Can you check whether a replacement would actually cause the string to be wrong in the editor?

Comment 6 Hedda Peters 2014-02-17 03:16:12 UTC
(In reply to David Mason from comment #5)
> (In reply to Hedda Peters from comment #4)
> > Sounds like a small little bug, but it could lead to wrong "replace"
> > operations, tag errors, and a translated document that won't build because
> > of them.
> 
> It looks like this may be purely a display issue, so I would be surprised if
> it causes tag errors or build failures. Can you check whether a replacement
> would actually cause the string to be wrong in the editor?

Yes, a replacement can cause the string to be wrong in the editor.

To stick with the example from my screenshots: If I search for ">-" and see the double ">>" in the result and therefore attempt to replace with " -" in order to remove the unwanted >, this does in fact remove the > character, which in reality existed only once - hence causing a tag error and failure to build, if not picked up. 

Having said that, the preview before replacing shows the correct characters. It is possible to realize the issue at that point and refrain from replacing. So it depends how careful the translator checks the preview before replacing.

Comment 8 Zanata Migrator 2015-07-31 01:49:39 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-563


Note You need to log in before you can comment on or make changes to this bug.