Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065713 - [NetworkLabels] LABELED_NETWORK_ATTACHED_TO_WRONG_INTERFACE entry in AppErrors is split to two lines
Summary: [NetworkLabels] LABELED_NETWORK_ATTACHED_TO_WRONG_INTERFACE entry in AppError...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.4.0
Assignee: Moti Asayag
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-16 08:53 UTC by Moti Asayag
Modified: 2014-04-01 05:06 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:28:57 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24511 None None None Never

Description Moti Asayag 2014-02-16 08:53:56 UTC
Description of problem:
In two of the AppErrors.properties files, the entry for LABELED_NETWORK_ATTACHED_TO_WRONG_INTERFACE was split into two lines:

frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties

Version-Release number of selected component (if applicable):


How reproducible:
this is a bit problematic, in order to reach this scenario, user should use the API, however in the API the message appears properly. This command isn't being used from the UI.

Steps to Reproduce:
1. Label a nic with a label that one of the networks it represents is already attach to other non-labeled nic on the same host. 

Actual results:


Expected results:


Additional info:

Comment 1 Sandro Bonazzola 2014-02-19 12:26:23 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 2 Martin Pavlik 2014-02-27 15:28:36 UTC
Moti,

should the ERROR be visible in GUI events? I can see it in log, but not in GUI. Is that expected?

2014-02-27 15:55:50,347 WARN  [org.ovirt.engine.core.bll.network.host.LabelNicCommand] (ajp--127.0.0.1-8702-11) [5d6c11d1] CanDoAction of action LabelNic failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__LABEL,LABELED_NETWORK_ATTACHED_TO_WRONG_INTERFACE,$AssignedNetworks NET1
2014-02-27 15:55:50,351 WARN  [org.ovirt.engine.core.utils.ErrorTranslatorImpl] (ajp--127.0.0.1-8702-11) Code MAC_ADDRESS_IS_IN_USE appears more than once in string table.
2014-02-27 15:55:50,365 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp--127.0.0.1-8702-11) Operation Failed: [Cannot add Label. The following networks are already attached to a different interface on the host: NET1. Please remove the networks in order to label the interface.]

Comment 3 Moti Asayag 2014-02-27 20:47:38 UTC
(In reply to Martin Pavlik from comment #2)
> Moti,
> 
> should the ERROR be visible in GUI events? I can see it in log, but not in
> GUI. Is that expected?
> 

No, it should be presented only when invoked via the api, or in the engine.log.
this command isn't being invoked from the UI and since this is a can-do-action message, there is no event log for it.

Comment 4 Sandro Bonazzola 2014-03-31 12:28:57 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.