Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065703 - kickstart 'partition' command insists on '--size' arg
Summary: kickstart 'partition' command insists on '--size' arg
Keywords:
Status: CLOSED DUPLICATE of bug 1067707
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-16 01:50 UTC by Bruce Jerrick
Modified: 2014-02-21 16:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-21 16:40:25 UTC


Attachments (Terms of Use)

Description Bruce Jerrick 2014-02-16 01:50:44 UTC
Description of problem:
The kickstart 'partition' command insists on having a '--size n' argument
even when it is not needed; e.g. when the disk is pre-partitioned.

Version-Release number of selected component:
anaconda-21.20-1.fc21

How reproducible:
100%

Steps to Reproduce:
1. Do a kickstart installation to a pre-partitioned disk (it doesn't have
   to be formatted), with 'partition' commands like this:

    clearpart --none
    partition / --fstype ext4 --onpart sda2

Actual results:
Installation fails with "The size None is not valid".

Expected results:
Installation succeeds (as it has in, e.g. Fedora 18).

Additional info:
The failure message is emitted by pyanaconda/kickstart.py .
A workaround is to use '--size 0'.  I see no difference in the resulting
partition table or filesystem sizes; that would seem to indicate it's
just a bug in the command parser.

Comment 1 Chris Lumens 2014-02-21 16:40:25 UTC
This should be fixed by the patch for bug 1067707.  Thanks for the report.

*** This bug has been marked as a duplicate of bug 1067707 ***


Note You need to log in before you can comment on or make changes to this bug.