Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065692 - SELinux is preventing /usr/sbin/postconf from 'read' accesses on the file .
Summary: SELinux is preventing /usr/sbin/postconf from 'read' accesses on the file .
Keywords:
Status: CLOSED DUPLICATE of bug 1065693
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:06b66a002f505462a56f705e44b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-15 22:18 UTC by Nicolas Mailhot
Modified: 2014-02-17 08:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-17 08:55:23 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2014-02-15 22:18:31 UTC
Description of problem:
SELinux is preventing /usr/sbin/postconf from 'read' accesses on the file .

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que postconf devrait être autorisé à accéder read sur  file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep postconf /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                unconfined_u:object_r:postfix_etc_t:s0
Target Objects                 [ file ]
Source                        postconf
Source Path                   /usr/sbin/postconf
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           postfix-2.11.0-1.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-24.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.14.0-0.rc2.git4.1.fc21.x86_64 #1
                              SMP Fri Feb 14 20:03:13 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-02-15 23:13:43 CET
Last Seen                     2014-02-15 23:13:43 CET
Local ID                      f693a0b6-d3e0-4c23-8c53-21b4877fba76

Raw Audit Messages
type=AVC msg=audit(1392502423.438:66): avc:  denied  { read } for  pid=1107 comm="postconf" name="main.cf" dev="dm-0" ino=655552 scontext=system_u:system_r:init_t:s0 tcontext=unconfined_u:object_r:postfix_etc_t:s0 tclass=file


type=SYSCALL msg=audit(1392502423.438:66): arch=x86_64 syscall=open success=no exit=EACCES a0=7fa837da9610 a1=0 a2=0 a3=7fa837da91f0 items=0 ppid=1105 pid=1107 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=postconf exe=/usr/sbin/postconf subj=system_u:system_r:init_t:s0 key=(null)

Hash: postconf,init_t,postfix_etc_t,file,read

Additional info:
reporter:       libreport-2.1.12
hashmarkername: setroubleshoot
kernel:         3.14.0-0.rc2.git4.1.fc21.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-02-17 08:55:23 UTC

*** This bug has been marked as a duplicate of bug 1065693 ***


Note You need to log in before you can comment on or make changes to this bug.