Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065687 - gdm: sometimes no users offered
Summary: gdm: sometimes no users offered
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-15 21:07 UTC by Emmanuel Touzery
Modified: 2014-04-25 13:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-03 12:16:30 UTC


Attachments (Terms of Use)

Description Emmanuel Touzery 2014-02-15 21:07:24 UTC
Description of problem:
Sometimes (randomly it seems), when I boot up my laptop, gdm offers no users at all and so login is impossible. I have only one user on the laptop. If I go to a text terminal and type sudo killall gdm, gdm restarts and the user appears. It appears to be a race condition as it appears randomly.

Version-Release number of selected component (if applicable):
gdm
Version     : 3.10.0.1
Release     : 1.fc20

How reproducible:
Randomly

Steps to Reproduce:
1. Turn on the computer
2. Wait for GDM

Actual results:
Sometimes no users displayed

Expected results:
My user should be displayed all the time

Additional info:
I think this problem didn't appear when I installed fedora20 and started appearing more recently.

Comment 1 Emmanuel Touzery 2014-03-03 12:16:30 UTC
The problem didn't manifest itself since I applied this upgrade: https://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20140210/1189685.html

So I think that was the cause. I'll reopen this bug if the problem occurs again, therefore proving me wrong.

Comment 2 jonathan baron 2014-03-18 11:01:19 UTC
This bug sounds similar to 1074319, for which I have received no response. Although I get no users listed, I can log in by entering my username, then entering my password, and then (and only then) choosing the session that I want (Mate). Same problem with lightdm. Three of my machines have this problem and one does not.

Given that I am the only user of all these machines from the console, I am trying to figure out how to bypass gdm/light completely and just go directly to my Mate session on boot.

Comment 3 Emmanuel Touzery 2014-03-18 11:48:05 UTC
As for me though the bug really did not occur anymore since then, in 15 days.

Comment 4 Jesus M. Rodriguez 2014-04-25 13:40:39 UTC
I just did an update in Fedora 20 and am stuck at the GDM with no users in the list. I have to use CTRL-ALT-F2, login. Then sudo killall gdm. That's the only way to fix it. Subsequent reboots don't always fix it, sometimes it takes 2 or 3 times, which can be highly annoying.


Note You need to log in before you can comment on or make changes to this bug.