Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065663 - [abrt] WARNING: CPU: 0 PID: 6690 at drivers/net/wireless/iwlwifi/dvm/sta.c:880 iwl_send_lq_cmd+0x267/0x270 [iwldvm]()
Summary: [abrt] WARNING: CPU: 0 PID: 6690 at drivers/net/wireless/iwlwifi/dvm/sta.c:88...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fedora-kernel-wireless-iwl
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:9020a8ca0938008b9d9a6e3ac1a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-15 14:26 UTC by Emmanuel Pacaud
Modified: 2015-08-17 12:24 UTC (History)
8 users (show)

Fixed In Version: kernel-3.13.6-100.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-10 06:51:21 UTC


Attachments (Terms of Use)
File: dmesg (deleted)
2014-02-15 14:26 UTC, Emmanuel Pacaud
no flags Details
Fix station leak whena assoc fails (deleted)
2014-02-18 08:36 UTC, Emmanuel Grumbach
no flags Details | Diff

Description Emmanuel Pacaud 2014-02-15 14:26:20 UTC
Additional info:
reporter:       libreport-2.1.12
WARNING: CPU: 0 PID: 6690 at drivers/net/wireless/iwlwifi/dvm/sta.c:880 iwl_send_lq_cmd+0x267/0x270 [iwldvm]()
Modules linked in: xfs libcrc32c usb_storage tcp_lp nls_utf8 vfat fat isofs fuse ip6t_rpfilter ip6t_REJECT xt_conntrack bnep bluetooth ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw mmc_block snd_hda_codec_hdmi snd_hda_codec_idt gpio_ich iTCO_wdt iTCO_vendor_support coretemp dell_wmi kvm_intel sparse_keymap snd_hda_intel kvm snd_hda_codec snd_hwdep snd_seq arc4 snd_seq_device dell_laptop iwldvm dcdbas snd_pcm mac80211 microcode joydev serio_raw uvcvideo videobuf2_vmalloc i2c_i801 videobuf2_memops videobuf2_core iwlwifi videodev snd_page_alloc media e1000e snd_timer cfg80211 snd soundcore sdhci_pci sdhci lpc_ich mmc_core mfd_core rfkill ptp shpchp pps_core wmi acpi_cpufreq binfmt_misc nfsd auth_rpcgss nfs_acl lockd sunrpc firewire_ohci i915 firewire_core i2c_algo_bit crc_itu_t drm_kms_helper drm i2c_core video
CPU: 0 PID: 6690 Comm: kworker/u4:1 Not tainted 3.12.10-300.fc20.x86_64 #1
Hardware name: Dell Inc. Latitude E4300                  /      , BIOS A22 04/13/2011
Workqueue: iwlwifi iwl_bg_scan_completed [iwldvm]
 0000000000000009 ffff8800a7811b48 ffffffff81667ed5 0000000000000000
 ffff8800a7811b80 ffffffff8106903d ffff8800d4fa17d0 00000000ffffffea
 ffff8800d4fa2650 ffff8800d4fa2650 ffff8800a7811c4c ffff8800a7811b90
Call Trace:
 [<ffffffff81667ed5>] dump_stack+0x45/0x56
 [<ffffffff8106903d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106911a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa050ac27>] iwl_send_lq_cmd+0x267/0x270 [iwldvm]
 [<ffffffffa050aeee>] iwl_restore_stations+0x2be/0x3a0 [iwldvm]
 [<ffffffffa0511939>] iwlagn_commit_rxon+0x829/0xe10 [iwldvm]
 [<ffffffffa0442265>] ? ieee80211_queue_delayed_work+0x45/0x50 [mac80211]
 [<ffffffffa0512936>] iwlagn_post_scan+0x96/0xb0 [iwldvm]
 [<ffffffffa050f9c4>] iwl_process_scan_complete+0x114/0x180 [iwldvm]
 [<ffffffffa050fca8>] iwl_bg_scan_completed+0x28/0x40 [iwldvm]
 [<ffffffff81083456>] process_one_work+0x176/0x430
 [<ffffffff8108408b>] worker_thread+0x11b/0x3a0
 [<ffffffff81083f70>] ? rescuer_thread+0x350/0x350
 [<ffffffff8108af30>] kthread+0xc0/0xd0
 [<ffffffff8108ae70>] ? insert_kthread_work+0x40/0x40
 [<ffffffff81676dfc>] ret_from_fork+0x7c/0xb0
 [<ffffffff8108ae70>] ? insert_kthread_work+0x40/0x40

Comment 1 Emmanuel Pacaud 2014-02-15 14:26:31 UTC
Created attachment 863590 [details]
File: dmesg

Comment 2 Emmanuel Grumbach 2014-02-18 08:36:28 UTC
Created attachment 864414 [details]
Fix station leak whena assoc fails

I am not sure this will fix it, but it is definitely worth to try it.
I think it is right anyway.

Comment 3 Stanislaw Gruszka 2014-02-19 10:02:20 UTC
Thanks for patch Emmanuel . I assume you applied it internally and will be pushed upstream soon.

Josh, please apply above patch as fix for this bug.

Comment 4 Emmanuel Grumbach 2014-02-19 10:49:28 UTC
Well... While I think the patch is right - it hasn't been reviewed internally yet, hence, it is not yet applied internally.

I am not sure it solves the bug, but it is definitely something related to this...

Comment 5 Stanislaw Gruszka 2014-02-19 11:57:23 UTC
I think bug is not reproducible, so it is better apply patch to fedora release and check if warning will happen again. But if warning is reproducible I can prepare test kernel with the patch.

Emmanuel (Pacaud :-), is this warning reproducible for you ?

Comment 6 Emmanuel Grumbach 2014-02-19 12:02:09 UTC
FWIW: I saw lots of failed assocaion attempts in the log - in case that helps to reproduction...

Comment 7 Josh Boyer 2014-03-07 14:09:02 UTC
Looks like this went upstream as ec6f678c74dbdb06a6a775bbb00f1d26c17c404b.  Sorry for not grabbing it sooner.  I'll get it in today (though I'm surprised it didn't make 3.13.6).

Comment 8 Josh Boyer 2014-03-07 16:05:20 UTC
Fixed in Fedora git.  Thanks again.

Comment 9 Fedora Update System 2014-03-07 22:52:52 UTC
kernel-3.13.6-100.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.13.6-100.fc19

Comment 10 Fedora Update System 2014-03-07 22:54:01 UTC
kernel-3.13.6-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.13.6-200.fc20

Comment 11 Fedora Update System 2014-03-09 04:40:20 UTC
Package kernel-3.13.6-100.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.13.6-100.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3651/kernel-3.13.6-100.fc19
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2014-03-10 06:51:21 UTC
kernel-3.13.6-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-03-15 15:24:51 UTC
kernel-3.13.6-100.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Emmanuel Pacaud 2015-08-17 12:24:27 UTC
I don't own this hardware anymore, so I can not say if it still happens.


Note You need to log in before you can comment on or make changes to this bug.