Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065660 - hosted-engine --deploy cannot import name mixins
Summary: hosted-engine --deploy cannot import name mixins
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.4.0
Assignee: Adam Litke
QA Contact: movciari
URL:
Whiteboard: integration
Depends On:
Blocks: 1046145 1046146 1046147 1055495 1066085 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-02-15 13:19 UTC by movciari
Modified: 2014-09-18 12:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1066085 (view as bug list)
Environment:
Last Closed:
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
spec fix (deleted)
2014-02-17 14:46 UTC, Adam Litke
sbonazzo: review+
Details | Diff

Description movciari 2014-02-15 13:19:35 UTC
Description of problem:
on RHEL6.5, hosted-engine from build is34.1 fails on import
# hosted-engine --deploy
***L:ERROR Internal error: cannot import name mixins

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.0.0-5

How reproducible:
always

Steps to Reproduce:
1. install RHEL6.5
2. install ovirt-hosted-engine-setup-1.0.0-5 with all dependencies
3. hosted-engine --deploy

Actual results:
fails with internal error

Expected results:
should start hosted-engine setup

Additional info:

Comment 1 Adam Litke 2014-02-17 13:20:05 UTC
I'll take a look at this...

Comment 2 Adam Litke 2014-02-17 14:46:30 UTC
Created attachment 864130 [details]
spec fix

Since we have applied some patches that modify the automake files, we must rerun autoreconf as part of the build to make sure our changes to the build are recognized.

Comment 3 Sandro Bonazzola 2014-02-17 15:04:51 UTC
Comment on attachment 864130 [details]
spec fix

Thanks Adam, it's missing build require on automake and autoconf but I've understood the issue.

Comment 4 Sandro Bonazzola 2014-02-17 15:06:01 UTC
This is affecting only packaging of hosted engine shipped with 3.3.1, so it's test only for 3.4.0.

Comment 6 Itamar Heim 2014-06-12 14:10:50 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.