Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065649 - Crack attack does not exit on closing window
Summary: Crack attack does not exit on closing window
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: crack-attack
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-15 11:40 UTC by Štefan Gurský
Modified: 2014-06-14 08:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-14 08:38:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNU Savannah 17839 None None None Never

Description Štefan Gurský 2014-02-15 11:40:58 UTC
Description of problem:
After closing crack attack window, the process is still running.

Version-Release number of selected component (if applicable):
Name        : crack-attack
Version     : 1.1.14
Release     : 26.fc20
Architecture: x86_64
Steps to Reproduce:
1. run crack-attack
2. close crack attack window using close button from window manager (X in corner)
3. observe that crack-attack process is still running

Actual results:
crack-attack process is still running

Expected results:
crack-attack process not running

Additional info:

There are similar bug reports for debian, ubuntu and for upstream and they seem to be quite old (for old versions of crack-attack)

For upstream: https://savannah.nongnu.org/bugs/?13163 and https://savannah.nongnu.org/bugs/?17839 (the second one seems to be duplicate, but there is link to csv with some fix: http://cvs.savannah.gnu.org/viewvc/crack-attack/src/gtk-gui/gui_main.cxx?root=crack-attack&r1=1.10&r2=1.11)

Comment 1 Hans de Goede 2014-06-14 08:38:08 UTC
Thanks for the bug report. and for the link to the upstream patch. I've just started a build for rawhide fixing this. I do not consider this a severe enough bug to issue an update for older Fedora releases.


Note You need to log in before you can comment on or make changes to this bug.