Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065470 - yum update fails for ImageMagick
Summary: yum update fails for ImageMagick
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ImageMagick
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Horak
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-14 17:58 UTC by Antonin Mares
Modified: 2017-12-06 12:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 12:19:22 UTC


Attachments (Terms of Use)

Description Antonin Mares 2014-02-14 17:58:39 UTC
Description of problem:

Attempt to update system with "yum update" command fails complaining about ImageMagick package.

Version-Release number of selected component (if applicable):
ImageMagick-perl-6.5.4.7-6.el6_2.x86_64
ImageMagick-6.5.4.7-6.el6_2.x86_64

Actual results:

yum update ImageMagick
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.5.4.7-6.el6_2 will be updated
--> Processing Dependency: ImageMagick = 6.5.4.7-6.el6_2 for package: ImageMagick-perl-6.5.4.7-6.el6_2.x86_64
---> Package ImageMagick.x86_64 0:6.5.4.7-7.el6_5 will be an update
--> Running transaction check
---> Package ImageMagick.i686 0:6.5.4.7-6.el6_2 will be installed
--> Processing Dependency: libwmflite-0.2.so.7 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libtiff.so.3 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: librsvg-2.so.2 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libpng12.so.0(PNG12_0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libpng12.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libltdl.so.7 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: liblcms.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libjpeg.so.62 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libjasper.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgs.so.8 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgomp.so.1(OMP_1.0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgomp.so.1(GOMP_1.0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgomp.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgobject-2.0.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgmodule-2.0.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libglib-2.0.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgdk_pixbuf-2.0.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libfreetype.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libfontconfig.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libcairo.so.2 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libbz2.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libXt.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libSM.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libICE.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
---> Package ImageMagick.x86_64 0:6.5.4.7-6.el6_2 will be updated
--> Running transaction check
---> Package bzip2-libs.i686 0:1.0.5-7.el6_0 will be installed
---> Package cairo.i686 0:1.8.8-3.1.el6 will be installed
--> Processing Dependency: libpixman-1.so.0 for package: cairo-1.8.8-3.1.el6.i686
--> Processing Dependency: libXrender.so.1 for package: cairo-1.8.8-3.1.el6.i686
---> Package fontconfig.i686 0:2.8.0-3.el6 will be installed
--> Processing Dependency: libexpat.so.1 for package: fontconfig-2.8.0-3.el6.i686
---> Package freetype.i686 0:2.3.11-14.el6_3.1 will be installed
---> Package ghostscript.i686 0:8.70-19.el6 will be installed
--> Processing Dependency: libkrb5.so.3 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libk5crypto.so.3 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libcupsimage.so.2 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libcups.so.2 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libcom_err.so.2 for package: ghostscript-8.70-19.el6.i686
---> Package glib2.i686 0:2.26.1-3.el6 will be installed
--> Processing Dependency: libselinux.so.1 for package: glib2-2.26.1-3.el6.i686
--> Processing Dependency: libfam.so.0 for package: glib2-2.26.1-3.el6.i686
---> Package gtk2.i686 0:2.20.1-4.el6 will be installed
--> Processing Dependency: libpangoft2-1.0.so.0 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libpangocairo-1.0.so.0 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libpango-1.0.so.0 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libatk-1.0.so.0 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXrandr.so.2 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXinerama.so.1 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXfixes.so.3 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXdamage.so.1 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXcursor.so.1 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXcomposite.so.1 for package: gtk2-2.20.1-4.el6.i686
---> Package jasper-libs.i686 0:1.900.1-15.el6_1.1 will be installed
---> Package lcms-libs.i686 0:1.19-1.el6 will be installed
---> Package libICE.i686 0:1.0.6-1.el6 will be installed
---> Package libSM.i686 0:1.2.1-2.el6 will be installed
--> Processing Dependency: libuuid.so.1(UUID_1.0) for package: libSM-1.2.1-2.el6.i686
--> Processing Dependency: libuuid.so.1 for package: libSM-1.2.1-2.el6.i686
---> Package libXt.i686 0:1.1.3-1.el6 will be installed
---> Package libgomp.i686 0:4.4.7-4.el6 will be installed
---> Package libjpeg-turbo.i686 0:1.2.1-3.el6_5 will be installed
---> Package libpng.i686 2:1.2.49-1.el6_2 will be installed
---> Package librsvg2.i686 0:2.26.0-6.el6_5.3 will be installed
--> Processing Dependency: libgsf-1.so.114 for package: librsvg2-2.26.0-6.el6_5.3.i686
--> Processing Dependency: libcroco-0.6.so.3 for package: librsvg2-2.26.0-6.el6_5.3.i686
---> Package libtiff.i686 0:3.9.4-9.el6_3 will be installed
---> Package libtool-ltdl.i686 0:2.2.6-15.5.el6 will be installed
---> Package libwmf-lite.i686 0:0.2.8.4-22.el6 will be installed
--> Running transaction check
---> Package atk.i686 0:1.30.0-1.el6 will be installed
---> Package cups-libs.i686 1:1.4.2-50.el6_4.5 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4) for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
--> Processing Dependency: libgnutls.so.26 for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
--> Processing Dependency: libavahi-common.so.3 for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
--> Processing Dependency: libavahi-client.so.3 for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
--> Processing Dependency: libaudit.so.1 for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
---> Package expat.i686 0:2.0.1-11.el6_2 will be installed
---> Package gamin.i686 0:0.1.10-9.el6 will be installed
---> Package krb5-libs.i686 0:1.10.3-10.el6_4.6 will be installed
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-10.el6_4.6.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-10.el6_4.6.i686
---> Package libXcomposite.i686 0:0.4.3-4.el6 will be installed
---> Package libXcursor.i686 0:1.1.13-6.20130524git8f677eaea.el6 will be installed
---> Package libXdamage.i686 0:1.1.3-4.el6 will be installed
---> Package libXfixes.i686 0:5.0-3.el6 will be installed
---> Package libXinerama.i686 0:1.1.2-2.el6 will be installed
---> Package libXrandr.i686 0:1.4.0-1.el6 will be installed
---> Package libXrender.i686 0:0.9.7-2.el6 will be installed
---> Package libcom_err.i686 0:1.41.12-18.el6 will be installed
---> Package libcroco.i686 0:0.6.2-5.el6 will be installed
---> Package libgsf.i686 0:1.14.15-5.el6 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
---> Package libuuid.i686 0:2.17.2-12.14.el6 will be installed
---> Package pango.i686 0:1.28.1-7.el6_3 will be installed
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1) for package: pango-1.28.1-7.el6_3.i686
--> Processing Dependency: libthai.so.0 for package: pango-1.28.1-7.el6_3.i686
--> Processing Dependency: libXft.so.2 for package: pango-1.28.1-7.el6_3.i686
---> Package pixman.i686 0:0.26.2-5.1.el6_5 will be installed
--> Running transaction check
---> Package audit-libs.i686 0:2.2-2.el6 will be installed
---> Package avahi-libs.i686 0:0.6.25-12.el6 will be installed
--> Processing Dependency: libdbus-1.so.3 for package: avahi-libs-0.6.25-12.el6.i686
---> Package gnutls.i686 0:2.8.5-10.el6_4.2 will be installed
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3) for package: gnutls-2.8.5-10.el6_4.2.i686
--> Processing Dependency: libtasn1.so.3 for package: gnutls-2.8.5-10.el6_4.2.i686
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: gnutls-2.8.5-10.el6_4.2.i686
--> Processing Dependency: libgcrypt.so.11 for package: gnutls-2.8.5-10.el6_4.2.i686
---> Package keyutils-libs.i686 0:1.4-4.el6 will be installed
---> Package libXft.i686 0:2.3.1-2.el6 will be installed
---> Package libthai.i686 0:0.1.12-3.el6 will be installed
--> Running transaction check
---> Package dbus-libs.i686 1:1.2.24-7.el6_3 will be installed
---> Package libgcrypt.i686 0:1.4.5-11.el6_4 will be installed
--> Processing Dependency: libgpg-error.so.0 for package: libgcrypt-1.4.5-11.el6_4.i686
---> Package libtasn1.i686 0:2.3-3.el6_2.1 will be installed
--> Running transaction check
---> Package libgpg-error.i686 0:1.7-4.el6 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for ImageMagick which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of ImageMagick of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude ImageMagick.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of ImageMagick installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of ImageMagick installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: ImageMagick-6.5.4.7-7.el6_5.x86_64 != ImageMagick-6.5.4.7-6.el6_2.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Antonin Mares 2014-02-14 18:14:12 UTC
Seems like problem can be solved by manualy uninstalling ImageMagick packages and installing them again. 
Altough it seems that ImageMagick-perl does not exists in current release so only ImageMagick can be installed.

Comment 3 Benjamin Tissoires 2014-02-14 18:22:43 UTC
Antonin, ImageMagick-perl is available in the optional repo. I am trying to figure out if it was the case before the update, but if so, you might have enabled it once, and then disabled it after.

Comment 4 Benjamin Tissoires 2014-02-19 13:52:08 UTC
Antonin, can you please confirm that you can install / update ImageMagick-perl with the optional repository enabled?

Comment 6 Antonin Mares 2014-02-19 14:31:39 UTC
I can try it, but I need hint how to enable the optional repository you are speaking about.

Comment 7 Benjamin Tissoires 2014-02-19 14:50:50 UTC
The doc is here:
https://access.redhat.com/site/documentation/en-US/Red_Hat_Subscription_Management/1/html/RHSM/entitlements-and-yum.html

you need to enable rhel-6-workstation-optional-rpms (or whatever your flavor is):
~# subscription-manager repos --enable rhel-6-workstation-optional-rpms

Comment 8 Antonin Mares 2014-02-20 09:04:07 UTC
After enabling optional repository it seems, that yum can install ImageMagick-perl.

Thanks for info.

Comment 9 john broome 2014-03-06 17:25:32 UTC
I am having the same issue, but with a straight update to ImageMagick, ImageMagick-perl isn't installed:

root@dpc-app-2 sadf]# rpm -qa | grep Image
ImageMagick-6.5.4.7-6.el6_2.x86_64
ImageMagick-devel-6.5.4.7-6.el6_2.x86_64

[root@dpc-app-2 sadf]# uname -a
Linux dpc-app-2 2.6.32-431.3.1.el6.x86_64 #1 SMP Fri Dec 13 06:58:20 EST 2013 x86_64 x86_64 x86_64 GNU/Linux

root@dpc-app-2 sadf]# rpm -q redhat-release-server
redhat-release-server-6Server-6.5.0.1.el6.x86_64

yum update
Loaded plugins: product-id, rhnplugin, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
percona                                                                                                                                                    |  951 B     00:00
percona/primary                                                                                                                                            |  60 kB     00:00
percona                                                                                                                                                                   203/203
rhel-x86_64-server-6                                                                                                                                       | 1.8 kB     00:00
rhel-x86_64-server-6/primary                                                                                                                               |  16 MB     00:00
rhel-x86_64-server-6                                                                                                                                                  12310/12310
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.5.4.7-6.el6_2 will be updated
--> Processing Dependency: ImageMagick = 6.5.4.7-6.el6_2 for package: ImageMagick-devel-6.5.4.7-6.el6_2.x86_64
---> Package ImageMagick.x86_64 0:6.5.4.7-7.el6_5 will be an update
--> Processing Dependency: libImath.so.6()(64bit) for package: ImageMagick-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: libIlmThread.so.6()(64bit) for package: ImageMagick-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: libIlmImf.so.6()(64bit) for package: ImageMagick-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: libIex.so.6()(64bit) for package: ImageMagick-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: libHalf.so.6()(64bit) for package: ImageMagick-6.5.4.7-7.el6_5.x86_64
---> Package gnutls.x86_64 0:2.8.5-10.el6_4.2 will be updated
---> Package gnutls.x86_64 0:2.8.5-13.el6_5 will be an update
---> Package initscripts.x86_64 0:9.03.40-2.el6 will be updated
---> Package initscripts.x86_64 0:9.03.40-2.el6_5.1 will be an update
---> Package librsvg2.x86_64 0:2.26.0-6.el6_5.2 will be updated
---> Package librsvg2.x86_64 0:2.26.0-6.el6_5.3 will be an update
---> Package libtiff.x86_64 0:3.9.4-9.el6_3 will be updated
---> Package libtiff.x86_64 0:3.9.4-10.el6_5 will be an update
---> Package libtiff-devel.x86_64 0:3.9.4-9.el6_3 will be updated
---> Package libtiff-devel.x86_64 0:3.9.4-10.el6_5 will be an update
---> Package nss.x86_64 0:3.15.3-3.el6_5 will be updated
---> Package nss.x86_64 0:3.15.3-6.el6_5 will be an update
---> Package nss-sysinit.x86_64 0:3.15.3-3.el6_5 will be updated
---> Package nss-sysinit.x86_64 0:3.15.3-6.el6_5 will be an update
---> Package nss-tools.x86_64 0:3.15.3-3.el6_5 will be updated
---> Package nss-tools.x86_64 0:3.15.3-6.el6_5 will be an update
---> Package postfix.x86_64 2:2.6.6-2.2.el6_1 will be updated
---> Package postfix.x86_64 2:2.6.6-6.el6_5 will be an update
---> Package psmisc.x86_64 0:22.6-15.el6_0.1 will be updated
---> Package psmisc.x86_64 0:22.6-19.el6_5 will be an update
---> Package upstart.x86_64 0:0.6.5-12.el6_4.1 will be updated
---> Package upstart.x86_64 0:0.6.5-13.el6_5.2 will be an update
---> Package wget.x86_64 0:1.12-1.8.el6 will be updated
---> Package wget.x86_64 0:1.12-1.11.el6_5 will be an update
---> Package yum-utils.noarch 0:1.1.30-14.el6 will be updated
---> Package yum-utils.noarch 0:1.1.30-17.el6_5 will be an update
--> Running transaction check
---> Package ImageMagick.i686 0:6.5.4.7-6.el6_2 will be installed
--> Processing Dependency: libz.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.4.30) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libxml2.so.2 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libwmflite-0.2.so.7 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libtiff.so.3 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: librsvg-2.so.2 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.2) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libpthread.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libpng12.so.0(PNG12_0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libpng12.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libm.so.6(GLIBC_2.1) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libm.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libltdl.so.7 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: liblcms.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libjpeg.so.62 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libjasper.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgs.so.8 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgomp.so.1(OMP_1.0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgomp.so.1(GOMP_1.0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgomp.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgobject-2.0.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgmodule-2.0.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libglib-2.0.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgdk_pixbuf-2.0.so.0 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libgcc_s.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libfreetype.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libfontconfig.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libcairo.so.2 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6(GLIBC_2.11) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libc.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libbz2.so.1 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libXt.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libXext.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libX11.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libSM.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
--> Processing Dependency: libICE.so.6 for package: ImageMagick-6.5.4.7-6.el6_2.i686
---> Package ImageMagick.x86_64 0:6.5.4.7-6.el6_2 will be updated
---> Package OpenEXR-libs.x86_64 0:1.6.1-8.1.el6 will be installed
---> Package ilmbase.x86_64 0:1.0.1-6.1.el6 will be installed
--> Running transaction check
---> Package bzip2-libs.i686 0:1.0.5-7.el6_0 will be installed
---> Package cairo.i686 0:1.8.8-3.1.el6 will be installed
--> Processing Dependency: libpixman-1.so.0 for package: cairo-1.8.8-3.1.el6.i686
--> Processing Dependency: libXrender.so.1 for package: cairo-1.8.8-3.1.el6.i686
---> Package fontconfig.i686 0:2.8.0-3.el6 will be installed
--> Processing Dependency: libexpat.so.1 for package: fontconfig-2.8.0-3.el6.i686
---> Package freetype.i686 0:2.3.11-14.el6_3.1 will be installed
---> Package ghostscript.i686 0:8.70-19.el6 will be installed
--> Processing Dependency: libstdc++.so.6 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libkrb5.so.3 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libk5crypto.so.3 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libcupsimage.so.2 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libcups.so.2 for package: ghostscript-8.70-19.el6.i686
--> Processing Dependency: libcom_err.so.2 for package: ghostscript-8.70-19.el6.i686
---> Package glib2.i686 0:2.26.1-3.el6 will be installed
--> Processing Dependency: libselinux.so.1 for package: glib2-2.26.1-3.el6.i686
--> Processing Dependency: libfam.so.0 for package: glib2-2.26.1-3.el6.i686
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.132.el6.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.132.el6.i686
---> Package gtk2.i686 0:2.20.1-4.el6 will be installed
--> Processing Dependency: libpangoft2-1.0.so.0 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libpangocairo-1.0.so.0 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libpango-1.0.so.0 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libatk-1.0.so.0 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXrandr.so.2 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXinerama.so.1 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXi.so.6 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXfixes.so.3 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXdamage.so.1 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXcursor.so.1 for package: gtk2-2.20.1-4.el6.i686
--> Processing Dependency: libXcomposite.so.1 for package: gtk2-2.20.1-4.el6.i686
---> Package jasper-libs.i686 0:1.900.1-15.el6_1.1 will be installed
---> Package lcms-libs.i686 0:1.19-1.el6 will be installed
---> Package libICE.i686 0:1.0.6-1.el6 will be installed
---> Package libSM.i686 0:1.2.1-2.el6 will be installed
--> Processing Dependency: libuuid.so.1(UUID_1.0) for package: libSM-1.2.1-2.el6.i686
--> Processing Dependency: libuuid.so.1 for package: libSM-1.2.1-2.el6.i686
---> Package libX11.i686 0:1.5.0-4.el6 will be installed
--> Processing Dependency: libxcb.so.1 for package: libX11-1.5.0-4.el6.i686
---> Package libXext.i686 0:1.3.1-2.el6 will be installed
---> Package libXt.i686 0:1.1.3-1.el6 will be installed
---> Package libgcc.i686 0:4.4.7-4.el6 will be installed
---> Package libgomp.i686 0:4.4.7-4.el6 will be installed
---> Package libjpeg-turbo.i686 0:1.2.1-3.el6_5 will be installed
---> Package libpng.i686 2:1.2.49-1.el6_2 will be installed
---> Package librsvg2.i686 0:2.26.0-6.el6_5.3 will be installed
--> Processing Dependency: libgsf-1.so.114 for package: librsvg2-2.26.0-6.el6_5.3.i686
--> Processing Dependency: libcroco-0.6.so.3 for package: librsvg2-2.26.0-6.el6_5.3.i686
---> Package libtiff.i686 0:3.9.4-10.el6_5 will be installed
---> Package libtool-ltdl.i686 0:2.2.6-15.5.el6 will be installed
---> Package libwmf-lite.i686 0:0.2.8.4-22.el6 will be installed
---> Package libxml2.i686 0:2.7.6-14.el6 will be installed
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package atk.i686 0:1.30.0-1.el6 will be installed
---> Package cups-libs.i686 1:1.4.2-50.el6_4.5 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4) for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
--> Processing Dependency: libgnutls.so.26 for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
--> Processing Dependency: libavahi-common.so.3 for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
--> Processing Dependency: libavahi-client.so.3 for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
--> Processing Dependency: libaudit.so.1 for package: 1:cups-libs-1.4.2-50.el6_4.5.i686
---> Package expat.i686 0:2.0.1-11.el6_2 will be installed
---> Package gamin.i686 0:0.1.10-9.el6 will be installed
---> Package krb5-libs.i686 0:1.10.3-10.el6_4.6 will be installed
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-10.el6_4.6.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-10.el6_4.6.i686
---> Package libXcomposite.i686 0:0.4.3-4.el6 will be installed
---> Package libXcursor.i686 0:1.1.13-6.20130524git8f677eaea.el6 will be installed
---> Package libXdamage.i686 0:1.1.3-4.el6 will be installed
---> Package libXfixes.i686 0:5.0-3.el6 will be installed
---> Package libXi.i686 0:1.6.1-3.el6 will be installed
---> Package libXinerama.i686 0:1.1.2-2.el6 will be installed
---> Package libXrandr.i686 0:1.4.0-1.el6 will be installed
---> Package libXrender.i686 0:0.9.7-2.el6 will be installed
---> Package libcom_err.i686 0:1.41.12-18.el6 will be installed
---> Package libcroco.i686 0:0.6.2-5.el6 will be installed
---> Package libgsf.i686 0:1.14.15-5.el6 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
---> Package libstdc++.i686 0:4.4.7-4.el6 will be installed
---> Package libuuid.i686 0:2.17.2-12.14.el6 will be installed
---> Package libxcb.i686 0:1.8.1-1.el6 will be installed
--> Processing Dependency: libXau.so.6 for package: libxcb-1.8.1-1.el6.i686
---> Package nss-softokn-freebl.i686 0:3.14.3-9.el6 will be installed
---> Package pango.i686 0:1.28.1-7.el6_3 will be installed
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1) for package: pango-1.28.1-7.el6_3.i686
--> Processing Dependency: libthai.so.0 for package: pango-1.28.1-7.el6_3.i686
--> Processing Dependency: libXft.so.2 for package: pango-1.28.1-7.el6_3.i686
---> Package pixman.i686 0:0.26.2-5.1.el6_5 will be installed
--> Running transaction check
---> Package audit-libs.i686 0:2.2-2.el6 will be installed
---> Package avahi-libs.i686 0:0.6.25-12.el6 will be installed
--> Processing Dependency: libdbus-1.so.3 for package: avahi-libs-0.6.25-12.el6.i686
---> Package gnutls.i686 0:2.8.5-13.el6_5 will be installed
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3) for package: gnutls-2.8.5-13.el6_5.i686
--> Processing Dependency: libtasn1.so.3 for package: gnutls-2.8.5-13.el6_5.i686
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: gnutls-2.8.5-13.el6_5.i686
--> Processing Dependency: libgcrypt.so.11 for package: gnutls-2.8.5-13.el6_5.i686
---> Package keyutils-libs.i686 0:1.4-4.el6 will be installed
---> Package libXau.i686 0:1.0.6-4.el6 will be installed
---> Package libXft.i686 0:2.3.1-2.el6 will be installed
---> Package libthai.i686 0:0.1.12-3.el6 will be installed
--> Running transaction check
---> Package dbus-libs.i686 1:1.2.24-7.el6_3 will be installed
---> Package libgcrypt.i686 0:1.4.5-11.el6_4 will be installed
--> Processing Dependency: libgpg-error.so.0 for package: libgcrypt-1.4.5-11.el6_4.i686
---> Package libtasn1.i686 0:2.3-3.el6_2.1 will be installed
--> Running transaction check
---> Package libgpg-error.i686 0:1.7-4.el6 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for ImageMagick which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of ImageMagick of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude ImageMagick.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of ImageMagick installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of ImageMagick installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: ImageMagick-6.5.4.7-6.el6_2.i686 != ImageMagick-6.5.4.7-7.el6_5.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 10 Pavel Alexeev 2015-10-04 21:15:44 UTC
It seams duplicate of bug#1208347

Comment 11 Jan Kurik 2017-12-06 12:19:22 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.