Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065407 - Incorrect exit code when ccs --stopall unable to stop cluster
Summary: Incorrect exit code when ccs --stopall unable to stop cluster
Keywords:
Status: CLOSED DUPLICATE of bug 1062402
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-14 15:28 UTC by Frantisek Reznicek
Modified: 2015-11-16 01:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-28 12:21:09 UTC


Attachments (Terms of Use)

Description Frantisek Reznicek 2014-02-14 15:28:01 UTC
Description of problem:

Incorrect exit code when ccs --stopall unable to stop cluster.

There are detected ccs executions like this:

root@mrg-jca-rhel6x_2:~# ccs -h $(hostname) -p ricci --stopall
Unable to stop 192.168.6.14.
Unable to stop 192.168.6.15.
Unable to stop 192.168.6.13.
root@mrg-jca-rhel6x_2:~# echo $?
0

It is incorrect to signal exit code of 0 when ccs command was unable to shutdown the whole cluster.


Version-Release number of selected component (if applicable):
ccs-0.16.2-69.el6_5.1.x86_64

How reproducible:
on specific machine 100%, case not seen on other clusters

Steps to Reproduce:
1. create cluster
2. enter state when ccs unable to manage it (don't know how atm)
3. ccs -h $(hostname) -p ricci --stopall
   eventually
   ccs -h <node-name> -p ricci --stopall
4. due to state 2. ccs fails to perform the operation but exit code is 0

Actual results:
  Bad exit code.

Expected results:
  Correct exit code.

Additional info:

root@mrg-jca-rhel6x_2:~# ccs -h $(hostname) -p ricci --stopall
echo $?
Unable to stop 192.168.6.14.
Unable to stop 192.168.6.15.
Unable to stop 192.168.6.13.
root@mrg-jca-rhel6x_2:~# echo $?
0
root@mrg-jca-rhel6x_2:~# ccs -h 192.168.6.14 -p ricci --stopall
Unable to stop 192.168.6.14.
Unable to stop 192.168.6.15.
Unable to stop 192.168.6.13.

Comment 3 Frantisek Reznicek 2014-02-14 16:29:15 UTC
(In reply to Frantisek Reznicek from comment #0)
> 
> Steps to Reproduce:
> 1. create cluster
> 2. enter state when ccs unable to manage it (don't know how atm)
> 3. ccs -h $(hostname) -p ricci --stopall
>    eventually
>    ccs -h <node-name> -p ricci --stopall
> 4. due to state 2. ccs fails to perform the operation but exit code is 0
> 

Step 2 state is reachable by stopping / uninstalling vm fencing daemon fence_virtd on infrastructure node.

Comment 4 Fabio Massimo Di Nitto 2014-02-28 12:21:09 UTC

*** This bug has been marked as a duplicate of bug 1062402 ***


Note You need to log in before you can comment on or make changes to this bug.