Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065381 - status bar does not contain online/offline icon and hover over link does not show link location
Summary: status bar does not contain online/offline icon and hover over link does not ...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 19
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-14 14:13 UTC by John Griffiths
Modified: 2014-03-31 09:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 09:20:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Adblock Plus 180 None None None Never

Description John Griffiths 2014-02-14 14:13:58 UTC
Description of problem:
When thunderbird starts only the "Unread: # Total: #" is in the status bar and it is all the way to the left of the bar. The online/offline icon is not in the status bar. When an email is displayed in the preview pane that has a link, hovering the mouse over the link does not display the link location.

Version-Release number of selected component (if applicable):
thunderbird-24.2.0-2.fc19.x86_64

How reproducible:
About 50% of the time, but once it happens, it stays that way until thunderbird is restarted in safe mode, exited, and started again.

Steps to Reproduce:
1. Start, exit, repeat until online/offline icon is not in the status bar.

Actual results:
Only the "Unread: # Total: #" is in the status bar and it is all the way to the left of the bar. The online/offline icon is not in the status bar. When an email is displayed in the preview pane that has a link, hovering the mouse over the link does not display the link location.

Expected results:
The online/offline icon should always be in the status bar. When an email is displayed in the preview pane that has a link, hovering the mouse over the link should display the link location.

Additional info:
Restarting in safe mode is not the only way to reset the status bar. If any add on is disabled and thunderbird restarted, then re-enabled and thunderbird restarted, the status bar will remain normal for a restart or two, sometimes more, but then the status bar will mess up again on a start. It does not seem to matter what add on is disabled. It is cycling that seems to reset something in the configuration so that the status bar returns to normal.

Comment 1 Jan Horak 2014-03-27 14:21:42 UTC
This seems to be addons issue, they can manipulate status bar. What addons do you have installed? If you have any installed try to disable them gradually and check if problem reoccurs.

Comment 2 John Griffiths 2014-03-27 17:03:46 UTC
I only have two extentions. Adblock Plus 2.5.1 and MoreFunctionsForAddressBook 0.6.9.1.

Appears that disabling Adblock Plus 2.5.1 cures the issue. I'll report to the add on developer.

Comment 3 John Griffiths 2014-03-27 17:15:57 UTC
There is a bug in the Adblock issue tracker. #180 Added bug URL.

Comment 4 Jan Horak 2014-03-31 09:20:55 UTC
Thank you for reporting your bug to upstream. We're going to track this problem there.


Note You need to log in before you can comment on or make changes to this bug.