Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065376 - RFE: yum updateinfo does not accept advisory name with respin suffix
Summary: RFE: yum updateinfo does not accept advisory name with respin suffix
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils
Version: 6.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Valentina Mukhamedzhanova
QA Contact: Eva Mrakova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-14 14:06 UTC by Miroslav Vadkerti
Modified: 2016-07-25 14:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1065364
Environment:
Last Closed: 2016-07-25 14:44:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miroslav Vadkerti 2014-02-14 14:06:42 UTC
The same issue is in subscription-manager-1.9.11-1.el6

+++ This bug was initially created as a clone of Bug #1065364 +++

Description of problem:
yum won't work with advisory strings that contain external respin suffix. Respin s sometimes also happen when errata had been already shipped and is live. I currently tested only with RHN classic.

For example on a RHEL6.5 machine I try to list updates for this errata:
https://rhn.redhat.com/errata/RHSA-2014-0127.html

That has advisory name:
RHSA-2014:0127-2

# yum updateinfo list --advisory RHSA-2014:0127-2
Loaded plugins: auto-update-debuginfo, product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Advisory "RHSA-2014:0127-2" not found applicable for this system
updateinfo list done

I have to remove the suffix to make it work:
# yum updateinfo list --advisory RHSA-2014:0127
Loaded plugins: auto-update-debuginfo, product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
RHSA-2014:0127 Moderate/Sec. librsvg2-2.26.0-6.el6_5.3.x86_64
updateinfo list done


Version-Release number of selected component (if applicable):
yum-utils-1.1.30-14.el6

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL
2. Register to RHN
3. Try to list an existing advisory with suffix in the name

Actual results:
No advisory found

Expected results:
Advisory found as without suffix

Additional info:
I will try out with the subscription manager also ...

--- Additional comment from Miroslav Vadkerti on 2014-02-14 08:57:19 EST ---

Does not work also if registered via subscription manager

Comment 2 William Poteat 2014-07-25 12:34:05 UTC
From an email exchange with Miroslav Vadkerti

The reproducer in the bugzilla expects you have librsvg2-2.26.0-6.el6_5.2 installed.
So you may need to downgrade if you have a 6.5.z machine.

# yum repolist | grep rhel-
rhel-6-server-cf-tools-1-rpms  Red Hat CloudForms Tools for RHEL 6 (RPMs)     31
rhel-6-server-rhev-agent-rpms  Red Hat Enterprise Virtualization Agents f     50
rhel-6-server-rpms             Red Hat Enterprise Linux 6 Server (RPMs)   12,732
rhel-ha-for-rhel-6-server-rpms Red Hat Enterprise Linux High Availability    377
rhel-lb-for-rhel-6-server-rpms Red Hat Enterprise Linux Load Balancer (fo     15
rhel-rs-for-rhel-6-server-rpms Red Hat Enterprise Linux Resilient Storage    431
rhel-x86_64-server-6.5.aus     RHEL AUS Server (v. 6.5 for 64-bit x86_64) 12,731

# yum downgrade librsvg2-2.26.0-6.el6_5.2

# rpm -q librsvg2
librsvg2-2.26.0-6.el6_5.2.x86_64

# yum updateinfo list --advisory RHSA-2014:0127-2
...
Advisory "RHSA-2014:0127-2" not found applicable for this system

# yum updateinfo list --advisory RHSA-2014:0127
...
RHSA-2014:0127 Moderate/Sec. librsvg2-2.26.0-6.el6_5.3.x86_64
updateinfo list done

Comment 3 William Poteat 2014-07-25 17:12:10 UTC
This functionality is not in subscription-manager. Will reassign to another area.

Comment 6 Eduard Benes 2014-12-15 12:02:16 UTC
Hello, I'm reopening this bug in order to improve user experience and allow administrators to update their systems to a specific errata using the exact same "Advisory" ID as is listed on RHN Errata page (e.g. [1]), not only in a high-level overview page of available advisories [2] where advisories are listed without the respin suffix. Another possible improvement is to re-design RHN page, and all other places where the respin suffix is currently used, to ignore the respin suffix and avoid user confusion. 

Marking it as a FutureFeature / enhancement. If this RFE is really not a RHEL 6 material, I would like to propose it for RHEL 7 via the bug 1065380 and agree with closing this for RHEL 6. Thank you.

1. https://rhn.redhat.com/errata/RHBA-2010-0943.html 
2. https://rhn.redhat.com/errata/rhel-server-6-errata.html

Comment 7 Valentina Mukhamedzhanova 2016-07-25 14:44:01 UTC
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

This issue is tracked in Red Hat Enterprise Linux 7 in bug 1065380.


Note You need to log in before you can comment on or make changes to this bug.