Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065329 - Rebase openstack-ceilometer to 2013.2.2
Summary: Rebase openstack-ceilometer to 2013.2.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: z2
: 4.0
Assignee: Eoghan Glynn
QA Contact: Shai Revivo
URL: https://launchpad.net/ceilometer/hava...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-14 11:16 UTC by Alan Pevec
Modified: 2014-03-04 20:17 UTC (History)
6 users (show)

Fixed In Version: openstack-ceilometer-2013.2.2-1.el6ost
Doc Type: Rebase: Bug Fixes Only
Doc Text:
Telemetry has been rebased with the upstream stable release 2013.2.2 The bugfixes contained in this release were backported from the development branches into a stable branch. The release is intended to be a relatively risk free update with no intentional regressions or API changes. Critical and High classified issues addressed by this rebase: The Mongo aggregation pipeline for resource retrieval failed with excessive memory use Cardinality of the storage.models.Resource.meter attribute was one-per-sample The instance.scheduled meter was not persistent The pep8 gating failed due to tools/config/check_uptodate.sh Could not create alarms successfully when following examples in community The complete list of upstream bugs fixed in this release can be found at https://launchpad.net/ceilometer/havana/2013.2.2
Clone Of: 1065280
Environment:
Last Closed: 2014-03-04 20:17:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1233103 None None None Never
Red Hat Product Errata RHBA-2014:0213 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-03-05 01:11:55 UTC
Launchpad 1245362 None None None Never
Launchpad 1268614 None None None Never
Launchpad 1272988 None None None Never

Description Alan Pevec 2014-02-14 11:16:42 UTC
This bugzilla is designed to track a rebase of openstack-ceilometer.  Please link any upstream issues not covered in Red Hat Bugzilla as well as other bugzillas (also covered by this rebase) to this one.

Comment 1 Eoghan Glynn 2014-02-14 13:04:05 UTC
Waiting for the PM ack before pushing and building.

Comment 2 Scott Lewis 2014-02-14 13:11:18 UTC
pm_ack for rebase to 2013.2.2

Comment 3 Eoghan Glynn 2014-02-14 13:16:02 UTC
Linked to Launchpad bugs upstream not already covered by Red Hat Bugzilla.

Also the rebase subsumed the following previously internally backported fixes:

  https://bugzilla.redhat.com1047872
  https://bugzilla.redhat.com1047877
  https://bugzilla.redhat.com1047882

Comment 5 Eoghan Glynn 2014-02-20 11:37:03 UTC
Manually verified that the rebased sources are present. As expected the only deltas seen were due to additional patches we carry in RHOS:

  $ wget http://tarballs.openstack.org/ceilometer/ceilometer-2013.2.2.tar.gz
  $ tar xvf ceilometer-2013.2.2.tar.gz 
  $ cd /usr/lib/python2.6/site-packages/ceilometer/
  $ for f in $(find . -name "*.py") ; do diff $f /tmp/ceilometer-2013.2.2/ceilometer/$f ; if [[ $? -ne 0 ]] ; then echo $f ; fi ; done
0a1
> #!/usr/bin/env python
./tests/base.py
16,37d15
< 
< import sys
< import pkg_resources
< 
< # If there is a conflicting non egg module,
< # i.e. an older standard system module installed,
< # then replace it with this requirement
< def replace_dist(requirement):
<     try:
<         return pkg_resources.require(requirement)
<     except pkg_resources.VersionConflict:
<         e = sys.exc_info()[1]
<         dist=e.args[0]
<         req=e.args[1]
<         if dist.key == req.key and not dist.location.endswith('.egg'):
<             del pkg_resources.working_set.by_key[dist.key]
<             # We assume there is no need to adjust sys.path
<             # and the associated pkg_resources.working_set.entries
<             return pkg_resources.require(requirement)
< 
< replace_dist("WebOb >= 1.2")
< replace_dist("SQLAlchemy >= 0.7.3")
./__init__.py
0a1
> #!/usr/bin/env python
./service.py
0a1
> #!/usr/bin/env python
./objectstore/swift_middleware.py
0a1
> #!/usr/bin/env python
./storage/sqlalchemy/migrate_repo/manage.py
58,64c58
< try:
<     # Try the more specific path first (migrate <= 0.6)
<     from migrate.versioning import exceptions as versioning_exceptions
< except ImportError:
<     # Use the newer path (migrate >= 0.7)
<     from migrate import exceptions as versioning_exceptions
< 
---
> from migrate import exceptions as versioning_exceptions
./storage/sqlalchemy/migration.py

Comment 7 errata-xmlrpc 2014-03-04 20:17:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0213.html


Note You need to log in before you can comment on or make changes to this bug.