Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065238 - The documentation lacks netty-servlet transport configuration [NEEDINFO]
Summary: The documentation lacks netty-servlet transport configuration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: EAP 6.3.0
Assignee: Nidhi
QA Contact: Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-14 07:44 UTC by Tyronne Wickramarathne
Modified: 2014-08-14 15:21 UTC (History)
6 users (show)

Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 14:41:07 UTC
Type: Bug
jmorgan: needinfo? (rdickens)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1089274 None None None Never

Internal Links: 1089274

Description Tyronne Wickramarathne 2014-02-14 07:44:36 UTC
Description of problem:

The documentation lacks any information on the use of 'netty tranport support' over http port, the netty-servlet transport support for remote JMS clients.

This helps users to configure the inbuilt netty-servlet to offer JMS clients to communicate over the configured HTTP port. Thus it eliminates the need to open a separate port for JMS clients to communicate to the broker, specially when the communication occurs over a firewall.

-Note-
Although it's possible for JMS clients to communicate over the HTTP port with the help of netty-servlet support; the netty service over HTTP cannot be used to configure a JBOss-EAP-6.x servers to setup a HornetQ cluster. Hence, please state this information on a separate box so that the users would know this limitation when using the netty-servlet.




Version-Release number of selected component (if applicable):

JBoss-EAP-6.2, HornetQ-2.3.x





How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jared MORGAN 2014-03-28 00:08:12 UTC
Hi Russell

For the record, Tyronne contacted me directly yesterday and was going to update this ticket with triage information. He must have got tied up with other work, so I'll do it for him.

==Summary==

Add this community content into enterprise docs: http://docs.jboss.org/hornetq/2.3.0.Final/docs/user-manual/html_single/#configuring-transports

Exclude core API content contained in this section unless core API content is supported in EAP.

Include the note in #Description.

Ask tywickra if you get stuck.

==IRC log follows==

<tywickra> Basically, we want to tell the customers "Don't use netty servlet transport to configure a cluster"
 But we don't mention anything on netty servlet transport in the documentation. 
<jmorgan> So you need Russell to get that recommendation into the docs.
<tywickra> Yes, so before we say "Z is not supported", we need to explain what is "Z" is all about 
<jmorgan> That sounds like we need to write a small conceptual piece on Netty Servlet Transport
<tywickra> You beat me to it :-)
<jmorgan> :D
 So this would go into the HornetQ docs for EAP 6.2 and greater.
<tywickra> Yes, true 
<jmorgan> the bug you linked seems to be focused on the code side of the issue
 what I think needs to happen is that the issue is cloned so you guys can continue working on the code.
 The cloned issue will be used to handle the docs.
 That way docs won't hold up the code stuff.
 Unless the linked BZ *is* the docs bug.
<tywickra> Oops 
 My apologies, I pasted the incorrect BZ
<jmorgan> Oh, OK.
 Glad I checked :D
<tywickra> Here it is : https://bugzilla.redhat.com/show_bug.cgi?id=1065238
<jmorgan> RGR, that's making more sense ;)
<tywickra> sorry, had a dumb moment with my copy+past ability :-D
<jmorgan> lol
 Is there any community content about NTS at the moment?
 http://docs.jboss.org/hornetq/2.2.5.Final/user-manual/en/html/configuring-transports.html
 is this close to the mark?
<tywickra> Basically, the netty servlet can only be used to connect to a standalone single HornetQ instance. It doesn't support failover either : https://bugzilla.redhat.com/show_bug.cgi?id=1073497
 I would use 2.3.0 docs, that's more closer to what we have released in EAP-6.2 
<jmorgan> http://docs.jboss.org/hornetq/2.3.0.Final/docs/user-manual/html_single/#configuring-transports
<tywickra> bingo 
<jmorgan> So it's worth capturing this chapter in its entirety in the EAP 6.2 docs, correct?
 Is there any unsupported stuff currently mentioned in that chapter?
* jmorgan is not familiar enough with EAP anymore to make the judgement, and I know the EAP docs team will be asking the same question.
<tywickra> I would weed out any content related to the core API
<jmorgan> Good tip. 
<tywickra> Unless you're happy to ship the core API with the official doc :-)
<jmorgan> That is not my call ;)
<tywickra> :-)
<jmorgan> So the ticket should be updated with a link to the community docs. And specify that content about the core API be excluded.
 Tell them you've spoken to me about it and we've got it down to that .

Comment 6 Martin Svehla 2014-07-25 11:53:36 UTC
Looks good, thanks!


Note You need to log in before you can comment on or make changes to this bug.