Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065173 - [RFE][neutron]: Add support for SR-IOV capable NIC based switching (HW VEB), such as Mellanox ConnectX Family
Summary: [RFE][neutron]: Add support for SR-IOV capable NIC based switching (HW VEB), ...
Keywords:
Status: CLOSED DUPLICATE of bug 1041376
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: Upstream M3
: 6.0 (Juno)
Assignee: RHOS Maint
QA Contact: Ofer Blaut
URL: https://blueprints.launchpad.net/neut...
Whiteboard: upstream_milestone_juno-3 upstream_st...
Depends On:
Blocks: 1041376
TreeView+ depends on / blocked
 
Reported: 2014-02-14 05:07 UTC by RHOS Integration
Modified: 2016-04-26 18:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-19 14:03:22 UTC


Attachments (Terms of Use)

Description RHOS Integration 2014-02-14 05:07:56 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/neutron/+spec/ml2-sriov-nic-switch.

Description:

Add  ML2 MechanismDriver for SR-IOV capable NIC based switching (HW VEB), such as Mellanox ConnectX Family .
This will initially support VLAN  networking type.
The ML2 Mechanism driver will require L2 Agent in order to manage and update networking settings.

This blueprint is based and subject to nova and neutron enhancements  to support SR-IOV ports added during the Icehouse release:
https://review.openstack.org/#/c/72452/
https://review.openstack.org/#/c/67500/
https://review.openstack.org/#/c/72334/
https://blueprints.launchpad.net/neutron/+spec/ml2-binding-profile


Specification URL (additional information):

None

Comment 1 Stephen Gordon 2014-02-20 00:55:32 UTC
Updating based on BP milestone

Comment 2 Nir Yechiel 2014-03-06 14:30:00 UTC
Updating based on upstream milestone

Comment 3 Nir Yechiel 2014-07-15 12:50:10 UTC
Spec is approved. Currently on track for J2.


ML2 mechanism driver (sriovnicswitch)
====================================

- Initially support only VLAN as network type
- Port binding is handled by VIF Driver via libvirt domain XML
- PCI vendor initially matching Mellanox ConnectX. If other NICs are used (e.g., Intel) there is a need to update 'supported_vendor_pci_devs' in ml2_conf_sriov.ini to include the card vendor

L2 agent (SriovNicSwitch L2 agent)
==================================

The agent is part of the spec, but is only required for port updates (e.g., if the pNIC supports virtual function admin state settings). For NIC that does not support dynamic updates, no need to deploy the agent, hence the 'agent_required' flag in ml2_conf_sriov.ini

Nova
====

See: 

BZ 1041376
https://blueprints.launchpad.net/nova/+spec/pci-passthrough-sriov

Comment 5 lpeer 2014-11-19 14:03:22 UTC

*** This bug has been marked as a duplicate of bug 1041376 ***


Note You need to log in before you can comment on or make changes to this bug.