Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065137 - Sphinx text builder fails with NotImplementedError: Unknown node: container
Summary: Sphinx text builder fails with NotImplementedError: Unknown node: container
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-sphinx
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matej Stuchlik
QA Contact: Filip Holec
URL:
Whiteboard:
Depends On:
Blocks: 1251890
TreeView+ depends on / blocked
 
Reported: 2014-02-14 01:52 UTC by Dan Callaghan
Modified: 2016-04-18 10:28 UTC (History)
8 users (show)

Fixed In Version: python-sphinx-1.1.3-9.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1251890 (view as bug list)
Environment:
Last Closed: 2015-08-12 10:28:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1601 normal SHIPPED_LIVE python-sphinx bug fix update 2015-08-12 14:28:45 UTC

Description Dan Callaghan 2014-02-14 01:52:50 UTC
Description of problem:
Text builder crashes when building a doc which uses the .. container directive.

Version-Release number of selected component (if applicable):
python-sphinx-1.1.3-8.el7

How reproducible:
always

Steps to Reproduce:
1. In Beaker's source tree, run: make -C documentation text
or,
1. Build "text" format of a Sphinx doc using the .. container directive

Actual results:
Fails to build:
Exception occurred:
  File "/usr/lib/python2.7/site-packages/sphinx/writers/text.py", line 736, in unknown_visit
    raise NotImplementedError('Unknown node: ' + node.__class__.__name__)
NotImplementedError: Unknown node: container

Expected results:
Should build successfully.

Additional info:
Upstream bug: https://bitbucket.org/birkenfeld/sphinx/issue/1018/
Upstream patch: https://bitbucket.org/birkenfeld/sphinx/commits/447fab1105ec

Comment 2 Dan Callaghan 2014-03-04 21:51:16 UTC
Not sure if RHEL is using the EasyFix keyword... but this is a very straightforward fix, it would be great if you could apply it since it is preventing Beaker from being built in RHEL7.

Comment 4 Bohuslav "Slavek" Kabrda 2015-02-05 11:41:19 UTC
devel_ack+, we can fix this by the referenced upstream patch.

Comment 8 Peter Hostačný 2015-08-05 12:47:31 UTC
Please add some information how to reproduce this bug. You can attach some code causing this exception. I spent a long time trying to make documentation from beaker source tree (if you thought source codes of beaker upstream project) and there is so many dependencies on extensions that i couldn't build documentation nor invoke this exception.

Comment 9 Dan Callaghan 2015-08-05 23:25:02 UTC
It seems the original Sphinx issue tracker on Bitbucket has gone away, which is unfortunate. The issue was moved to here:

https://github.com/sphinx-doc/sphinx/issues/1018

It shows a simple reproducer. I will spell it out here for clarity:

$ cat <<EOF >contents.rst
> .. container:: test
> 
>    test
> EOF
$ sphinx-build -C -b text . .
Running Sphinx v1.1.3
loading pickled environment... not yet created
building [text]: targets for 1 source files that are out of date
updating environment: 1 added, 0 changed, 0 removed
reading sources... [100%] 
looking for now-outdated files... none found
pickling environment... done
checking consistency... done
preparing documents... done
writing output... [100%] 
Exception occurred:
  File "/usr/lib/python2.7/site-packages/sphinx/writers/text.py", line 736, in unknown_visit
    raise NotImplementedError('Unknown node: ' + node.__class__.__name__)
NotImplementedError: Unknown node: container
The full traceback has been saved in /tmp/sphinx-err-37_H5_.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
Either send bugs to the mailing list at <http://groups.google.com/group/sphinx-dev/>,
or report them in the tracker at <http://bitbucket.org/birkenfeld/sphinx/issues/>. Thanks!

Comment 12 errata-xmlrpc 2015-08-12 10:28:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1601.html


Note You need to log in before you can comment on or make changes to this bug.