Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065135 - 502 Proxy Error claims to be DNS, but the name resolves.
Summary: 502 Proxy Error claims to be DNS, but the name resolves.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Rajat Chopra
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-14 01:37 UTC by Adam Miller
Modified: 2015-05-14 23:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-14 16:38:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Adam Miller 2014-02-14 01:37:17 UTC
DEBUG: rhc app create d1402131821drupal cron -k php-5.3 mysql-5.1 --from-code=git://github.com/openshift/drupal-quickstart.git --no-git
Using cron-1.4 (Cron 1.4) for 'cron'

Application Options
-------------------
Domain:      nagiosmonitor
Cartridges:  cron-1.4, php-5.3, mysql-5.1
Source Code: git://github.com/openshift/drupal-quickstart.git
Gear Size:   default
Scaling:     no

Creating application 'd1402131821drupal' ... ^[[B^[[B^[[B^[[B^[[B^[[B^[[Bdone

  MySQL 5.1 database added.  Please make note of these credentials:

       Root User: adminvK8FQv2
   Root Password: gkfcurKSChqd
   Database Name: d1402131821drupal

Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/

You can manage your new MySQL database by also embedding phpmyadmin.
The phpmyadmin username and password will be the same as the MySQL credentials above.

To schedule your scripts to run on a periodic basis, add the scripts to
your application's .openshift/cron/{minutely,hourly,daily,weekly,monthly}/
directories (and commit and redeploy your application).

Example: A script .openshift/cron/hourly/crony added to your application
         will be executed once every hour.
         Similarly, a script .openshift/cron/weekly/chronograph added
         to your application will be executed once every week.

Waiting for your DNS name to be available ... done

Your application 'd1402131821drupal' is now available.

  URL:        http://d1402131821drupal-nagiosmonitor.int.rhcloud.com/
  SSH to:     52fd6eb903ef6485cf000001@d1402131821drupal-nagiosmonitor.int.rhcloud.com
  Git remote: ssh://52fd6eb903ef6485cf000001@d1402131821drupal-nagiosmonitor.int.rhcloud.com/~/git/d1402131821drupal.git/

Run 'rhc show-app d1402131821drupal' for more details about your app.
Run 'rhc show-app d1402131821drupal' for more details about your app.
Exit Code: 0

 sudo -u nagios_monitor /usr/local/bin/nagios-ctl-app -v -e drupal -a d1402131821drupal succeeded!

Checking check_control_app http://d1402131821drupal-nagiosmonitor.int.rhcloud.com/...

HTTP Result Code=>502


Search string [ Welcome to ] not found in output.


HTTP Result Code=>502


Search string [ Welcome to ] not found in output.


HTTP Result Code=>502


Search string [ Welcome to ] not found in output.


HTTP Result Code=>502


Search string [ Welcome to ] not found in output.


HTTP Result Code=>502


Search string [ Welcome to ] not found in output.



ERROR: check_control_app failed.

[root@ex-std-node1.int ~]# host d1402131821drupal-nagiosmonitor.int.rhcloud.com
d1402131821drupal-nagiosmonitor.int.rhcloud.com is an alias for ex-std-node1.int.rhcloud.com.
ex-std-node1.int.rhcloud.com is an alias for ec2-54-196-181-105.compute-1.amazonaws.com.
ec2-54-196-181-105.compute-1.amazonaws.com has address 10.236.129.247

Comment 1 Adam Miller 2014-02-14 01:55:35 UTC
Another example:

Creating quickstart app...
Getting QuickStart ...
QuickStart Info:
{"id"=>"1", "name"=>"CakePHP", "website"=>"http://cakephp.org/", "initial_git_url"=>"git://github.com/openshift/cakephp-example.git", "cartridges"=>["php-5.3", "mysql-5.1"], "summary"=>"CakePHP is a rapid development framework for PHP which uses commonly known design patterns like Active Record, Association Data Mapping, Front Controller and MVC.", "tags"=>["php", "cakephp", "framework"], "admin_tags"=>[]}

Getting primary domain... nagiosmonitor
Creating QuickStart app...
Body Info:
 "{\"name\":\"d1402131821quickstart\",\"cartridges\":[\"php-5.3\",\"mysql-5.1\"],\"initial_git_url\":\"git://github.com/openshift/cakephp-example.git\"}"

Success!

Messages:
  info: Application d1402131821quickstart was created.
  result:
MySQL 5.1 database added.  Please make note of these credentials:

       Root User: adminqKMjTnk
   Root Password: 4m3LAw_CBlMj
   Database Name: d1402131821quickstart

Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/

You can manage your new MySQL database by also embedding phpmyadmin.
The phpmyadmin username and password will be the same as the MySQL credentials above.
Exit Code: 0


Accessing page (retries left 6) at http://d1402131821quickstart-nagiosmonitor.int.rhcloud.com/...
Accessing page (retries left 5) at http://d1402131821quickstart-nagiosmonitor.int.rhcloud.com/...
Accessing page (retries left 4) at http://d1402131821quickstart-nagiosmonitor.int.rhcloud.com/...
Accessing page (retries left 3) at http://d1402131821quickstart-nagiosmonitor.int.rhcloud.com/...
Accessing page (retries left 2) at http://d1402131821quickstart-nagiosmonitor.int.rhcloud.com/...
Accessing page (retries left 1) at http://d1402131821quickstart-nagiosmonitor.int.rhcloud.com/...


ERROR: accessing page returned 502:
Body:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>502 Proxy Error</title>
</head><body>
<h1>Proxy Error</h1>
<p>The proxy server received an invalid
response from an upstream server.<br />
The proxy server could not handle the request <em><a href="/">GET&nbsp;/</a></em>.<p>
Reason: <strong>DNS lookup failure for: 127.10.157.1:8080|52fd765803ef64063200012d|52fd765803ef64063200012d</strong></p></p>
<hr>
<address>Apache/2.2.22 (Red Hat Enterprise Web Server) Server at d1402131821quickstart-nagiosmonitor.int.rhcloud.com Port 80</address>
</body></html>

Comment 2 Xiaoli Tian 2014-02-14 09:48:35 UTC
Looks like this bug is similar to  bug 1063611 reported against INT 3 days ago

Comment 3 Andy Goldstein 2014-02-14 13:47:38 UTC
Please make sure that /etc/httpd/conf.d/openshift_route.include contains the following lines (https://github.com/openshift/origin-server/blob/master/plugins/frontend/apache-mod-rewrite/httpd/openshift_route.include#L142-L144) and that httpd has been restarted on ALL nodes in INT.

Comment 4 Adam Miller 2014-02-14 16:38:24 UTC
It turns out that one of our nodes somehow and for some reason has the wrong configuration file and that's what's causing the issue. This is an Ops issue and not a bug.

Sorry for the line noise.


Note You need to log in before you can comment on or make changes to this bug.