Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065125 - 2.0.40 - Drupal app creation during INT deploy fails
Summary: 2.0.40 - Drupal app creation during INT deploy fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Templates
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Vojtech Vitek
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-14 01:04 UTC by Adam Miller
Modified: 2015-05-15 02:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-12 03:07:22 UTC


Attachments (Terms of Use)

Description Adam Miller 2014-02-14 01:04:43 UTC
Rerunning Step: create_php_app, try 1
  Current Time: 2014-02-13 18:32:55 -0500


Creating php app...
DEBUG: rhc app create d1402131821php cron -k php-5.3 mysql-5.1 --from-code=git://github.com/openshift/drupal-quickstart.git --no-git
Using cron-1.4 (Cron 1.4) for 'cron'

Application Options
-------------------
Domain:      nagiosmonitor
Cartridges:  cron-1.4, php-5.3, mysql-5.1
Source Code: git://github.com/openshift/drupal-quickstart.git
Gear Size:   default
Scaling:     no

Creating application 'd1402131821php' ... The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 52fd562b03ef647494000045 -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c1,c525' /bin/sh -c \"gear postreceive --init >> /tmp/initial-build.log 2>&1\""' returned an error. rc=255

.Last 10 kB of build output:
Stopping PHP 5.3 cartridge (Apache+mod_php)
Stopping MySQL 5.1 cartridge
Stopping Cron cartridge
Repairing links for 1 deployments
Building git ref 'master', commit ef72195
Checking deplist.txt for PEAR dependency..
Checking PEAR: pear.drush.org/drush

Attempting to discover channel "pear.drush.org"...
downloading channel.xml ...
Starting to download channel.xml (804 bytes)
....done: 804 bytes
Auto-discovered channel "pear.drush.org", alias "drush", adding to registry

Notice: Array to string conversion in 13.php on line 80
PHP Notice:  Array to string conversion in /usr/share/pear/PEAR/REST/13.php on line 80
PHP Stack trace:
PHP   1. {main}() /usr/share/pear/pearcmd.php:0
PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
PHP   3. PEAR_Command_Install->doInstall() /usr/share/pear/PEAR/Command/Common.php:271
PHP   4. PEAR_Downloader->download() /usr/share/pear/PEAR/Command/Install.php:661
PHP   5. PEAR_Downloader_Package->initialize() /usr/share/pear/PEAR/Downloader.php:279
PHP   6. PEAR_Downloader_Package->_fromString() /usr/share/pear/PEAR/Downloader/Package.php:190
PHP   7. PEAR_Downloader->_getPackageDownloadUrl() /usr/share/pear/PEAR/Downloader/Package.php:1713
PHP   8. PEAR_REST_13->getDownloadURL() /usr/share/pear/PEAR/Downloader.php:850

Warning: Invalid argument supplied for foreach() in 13.php on line 84
PHP Warning:  Invalid argument supplied for foreach() in /usr/share/pear/PEAR/REST/13.php on line 84
PHP Stack trace:
PHP   1. {main}() /usr/share/pear/pearcmd.php:0
PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
PHP   3. PEAR_Command_Install->doInstall() /usr/share/pear/PEAR/Command/Common.php:271
PHP   4. PEAR_Downloader->download() /usr/share/pear/PEAR/Command/Install.php:661
PHP   5. PEAR_Downloader_Package->initialize() /usr/share/pear/PEAR/Downloader.php:279
PHP   6. PEAR_Downloader_Package->_fromString() /usr/share/pear/PEAR/Downloader/Package.php:190
PHP   7. PEAR_Downloader->_getPackageDownloadUrl() /usr/share/pear/PEAR/Downloader/Package.php:1713
PHP   8. PEAR_REST_13->getDownloadURL() /usr/share/pear/PEAR/Downloader.php:850
PHP Fatal error:  Cannot use string offset as an array in /usr/share/pear/PEAR/REST/10.php on line 263
PHP Stack trace:
PHP   1. {main}() /usr/share/pear/pearcmd.php:0
PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
PHP   3. PEAR_Command_Install->doInstall() /usr/share/pear/PEAR/Command/Common.php:271
PHP   4. PEAR_Downloader->download() /usr/share/pear/PEAR/Command/Install.php:661
PHP   5. PEAR_Downloader_Package->initialize() /usr/share/pear/PEAR/Downloader.php:279
PHP   6. PEAR_Downloader_Package->_fromString() /usr/share/pear/PEAR/Downloader/Package.php:190
PHP   7. PEAR_Downloader->_getPackageDownloadUrl() /usr/share/pear/PEAR/Downloader/Package.php:1713
PHP   8. PEAR_REST_13->getDownloadURL() /usr/share/pear/PEAR/Downloader.php:850
PHP   9. PEAR_REST_10->_returnDownloadURL() /usr/share/pear/PEAR/REST/13.php:142
An error occurred executing 'gear postreceive' (exit code: 255)
Error message: CLIENT_ERROR: Failed to execute: 'control build' for /var/lib/openshift/52fd562b03ef647494000045/php

For more details about the problem, try running the command again with the '--trace' option.
For more details about the problem, try running the command again with the '--trace' option.
Exit Code: 0

sudo -u nagios_monitor /usr/local/bin/nagios-ctl-app -d -v -e drupal -a d1402131821php succeeded!

Checking check_control_app http://d1402131821php-nagiosmonitor.int.rhcloud.com/...

HTTP Result Code=>302


Search string [ Welcome to ] not found in output.


HTTP Result Code=>302


Search string [ Welcome to ] not found in output.


HTTP Result Code=>302


Search string [ Welcome to ] not found in output.


HTTP Result Code=>302


Search string [ Welcome to ] not found in output.


HTTP Result Code=>302


Search string [ Welcome to ] not found in output.



ERROR: check_control_app failed.

Comment 1 Wei Sun 2014-02-14 09:30:38 UTC
I tried to create drupal quickstart on devenv_4375,try three times.Failed twice,and last time could create druapl quickstart successfully.

Result:
1.Failed:
[root@ip-10-168-37-186 ~]# rhc app create drupal2 php-5.3 mysql-5.1 cron --from-code=git://github.com/openshift/drupal-quickstart.git --no-git
Using cron-1.4 (Cron 1.4) for 'cron'

Application Options
-------------------
Domain:      wsundev4375
Cartridges:  php-5.3, mysql-5.1, cron-1.4
Source Code: git://github.com/openshift/drupal-quickstart.git
Gear Size:   default
Scaling:     no

Creating application 'drupal2' ... 
The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 52fddfc31d2a357bb2000064 -c "exec /usr/bin/runcon
'unconfined_u:system_r:openshift_t:s0:c2,c222' /bin/sh -c \"gear postreceive --init >> /tmp/initial-build.log 2>&1\""' returned an error. rc=255

.Last 10 kB of build output:
Stopping Cron cartridge
Stopping PHP 5.3 cartridge (Apache+mod_php)
Stopping MySQL 5.1 cartridge
Repairing links for 1 deployments
Building git ref 'master', commit ef72195
Checking deplist.txt for PEAR dependency..
Checking PEAR: pear.drush.org/drush

Attempting to discover channel "pear.drush.org"...
downloading channel.xml ...
Starting to download channel.xml (804 bytes)
....done: 804 bytes
Auto-discovered channel "pear.drush.org", alias "drush", adding to registry

Notice: Array to string conversion in 13.php on line 80
PHP Notice:  Array to string conversion in /usr/share/pear/PEAR/REST/13.php on line 80
PHP Stack trace:
PHP   1. {main}() /usr/share/pear/pearcmd.php:0
PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
PHP   3. PEAR_Command_Install->doInstall() /usr/share/pear/PEAR/Command/Common.php:271
PHP   4. PEAR_Downloader->download() /usr/share/pear/PEAR/Command/Install.php:661
PHP   5. PEAR_Downloader_Package->initialize() /usr/share/pear/PEAR/Downloader.php:279
PHP   6. PEAR_Downloader_Package->_fromString() /usr/share/pear/PEAR/Downloader/Package.php:190
PHP   7. PEAR_Downloader->_getPackageDownloadUrl() /usr/share/pear/PEAR/Downloader/Package.php:1713
PHP   8. PEAR_REST_13->getDownloadURL() /usr/share/pear/PEAR/Downloader.php:850

Warning: Invalid argument supplied for foreach() in 13.php on line 84
PHP Warning:  Invalid argument supplied for foreach() in /usr/share/pear/PEAR/REST/13.php on line 84
PHP Stack trace:
PHP   1. {main}() /usr/share/pear/pearcmd.php:0
PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
PHP   3. PEAR_Command_Install->doInstall() /usr/share/pear/PEAR/Command/Common.php:271
PHP   4. PEAR_Downloader->download() /usr/share/pear/PEAR/Command/Install.php:661
PHP   5. PEAR_Downloader_Package->initialize() /usr/share/pear/PEAR/Downloader.php:279
PHP   6. PEAR_Downloader_Package->_fromString() /usr/share/pear/PEAR/Downloader/Package.php:190
PHP   7. PEAR_Downloader->_getPackageDownloadUrl() /usr/share/pear/PEAR/Downloader/Package.php:1713
PHP   8. PEAR_REST_13->getDownloadURL() /usr/share/pear/PEAR/Downloader.php:850
PHP Fatal error:  Cannot use string offset as an array in /usr/share/pear/PEAR/REST/10.php on line 263
PHP Stack trace:
PHP   1. {main}() /usr/share/pear/pearcmd.php:0
PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
PHP   3. PEAR_Command_Install->doInstall() /usr/share/pear/PEAR/Command/Common.php:271
PHP   4. PEAR_Downloader->download() /usr/share/pear/PEAR/Command/Install.php:661
PHP   5. PEAR_Downloader_Package->initialize() /usr/share/pear/PEAR/Downloader.php:279
PHP   6. PEAR_Downloader_Package->_fromString() /usr/share/pear/PEAR/Downloader/Package.php:190
PHP   7. PEAR_Downloader->_getPackageDownloadUrl() /usr/share/pear/PEAR/Downloader/Package.php:1713
PHP   8. PEAR_REST_13->getDownloadURL() /usr/share/pear/PEAR/Downloader.php:850
PHP   9. PEAR_REST_10->_returnDownloadURL() /usr/share/pear/PEAR/REST/13.php:142
An error occurred executing 'gear postreceive' (exit code: 255)
Error message: CLIENT_ERROR: Failed to execute: 'control build' for /var/lib/openshift/52fddfc31d2a357bb2000064/php

For more details about the problem, try running the command again with the '--trace' option.


2.Create drupal successfully
[root@ip-10-168-37-186 ~]# rhc app create drupal php-5.3 mysql-5.1 cron --from-code=git://github.com/openshift/drupal-quickstart.git --no-git
Using cron-1.4 (Cron 1.4) for 'cron'

Application Options
-------------------
Domain:      wsundev4375
Cartridges:  php-5.3, mysql-5.1, cron-1.4
Source Code: git://github.com/openshift/drupal-quickstart.git
Gear Size:   default
Scaling:     no

Creating application 'drupal' ... done

  MySQL 5.1 database added.  Please make note of these credentials:

       Root User: admin7rZ7Q2V
   Root Password: KDWmlb9e5rG_
   Database Name: drupal

Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/

You can manage your new MySQL database by also embedding phpmyadmin.
The phpmyadmin username and password will be the same as the MySQL credentials above.

To schedule your scripts to run on a periodic basis, add the scripts to 
your application's .openshift/cron/{minutely,hourly,daily,weekly,monthly}/
directories (and commit and redeploy your application).

Example: A script .openshift/cron/hourly/crony added to your application
         will be executed once every hour.
         Similarly, a script .openshift/cron/weekly/chronograph added
         to your application will be executed once every week.

Waiting for your DNS name to be available ... done

Your application 'drupal' is now available.

  URL:        http://drupal-wsundev4375.dev.rhcloud.com/
  SSH to:     52fde0661d2a357bb200007c@drupal-wsundev4375.dev.rhcloud.com
  Git remote: ssh://52fde0661d2a357bb200007c@drupal-wsundev4375.dev.rhcloud.com/~/git/drupal.git/

Run 'rhc show-app drupal' for more details about your app.

Comment 2 Ma xiaoqiang 2014-02-18 06:14:37 UTC
This problem exists on puddle [2.0.3/2014-02-12.1]

Comment 3 Adam Miller 2014-02-18 18:10:09 UTC
This is failing on STG and PROD currently.

Comment 4 Rajat Chopra 2014-02-18 18:33:32 UTC
Upstream issue : https://github.com/drush-ops/drush/issues/465

Comment 5 Vojtech Vitek 2014-02-19 14:28:14 UTC
Can't reproduce at the moment. Probably fixed in Drush UPSTREAM.

Comment 6 Vojtech Vitek 2014-02-19 14:44:30 UTC
Just for reference:
Upstream issue https://github.com/drush-ops/drush/issues/465 points to Composer support. Trello card for Composer: https://trello.com/c/tfekadvd

Comment 7 Wei Sun 2014-02-20 05:15:10 UTC
Tested this bug on STG(devenv-stage_703),now could create drupal successfully.

Result:
[wsun@dhcp-8-229 test]$ rhc app create drupal2 php-5.3 mysql-5.1 cron --from-code=git://github.com/openshift/drupal-quickstart.git --no-git
Using cron-1.4 (Cron 1.4) for 'cron'

Application Options
-------------------
Domain:      wsunstg
Cartridges:  php-5.3, mysql-5.1, cron-1.4
Source Code: git://github.com/openshift/drupal-quickstart.git
Gear Size:   default
Scaling:     no

Creating application 'drupal2' ... done

  MySQL 5.1 database added.  Please make note of these credentials:

       Root User: adminER36bfQ
   Root Password: 3mxZfLyU1UFb
   Database Name: drupal2

Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/

You can manage your new MySQL database by also embedding phpmyadmin.
The phpmyadmin username and password will be the same as the MySQL credentials above.

To schedule your scripts to run on a periodic basis, add the scripts to 
your application's .openshift/cron/{minutely,hourly,daily,weekly,monthly}/
directories (and commit and redeploy your application).

Example: A script .openshift/cron/hourly/crony added to your application
         will be executed once every hour.
         Similarly, a script .openshift/cron/weekly/chronograph added
         to your application will be executed once every week.

Waiting for your DNS name to be available ... done

Your application 'drupal2' is now available.

  URL:        http://drupal2-wsunstg.stg.rhcloud.com/
  SSH to:     53058e66dbd93cbb29000858@drupal2-wsunstg.stg.rhcloud.com
  Git remote: ssh://53058e66dbd93cbb29000858@drupal2-wsunstg.stg.rhcloud.com/~/git/drupal2.git/

Run 'rhc show-app drupal2' for more details about your app.


Note You need to log in before you can comment on or make changes to this bug.