Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065087 - BUG: scheduling while atomic (serial)
Summary: BUG: scheduling while atomic (serial)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1081017 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 21:51 UTC by Hal Murray
Modified: 2014-03-28 09:39 UTC (History)
8 users (show)

Fixed In Version: kernel-3.13.5-103.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-06 08:09:09 UTC


Attachments (Terms of Use)
Details from /var/log/messages (deleted)
2014-02-13 21:51 UTC, Hal Murray
no flags Details
more from /var/log/messages (deleted)
2014-02-13 22:00 UTC, Hal Murray
no flags Details

Description Hal Murray 2014-02-13 21:51:37 UTC
Created attachment 862996 [details]
Details from /var/log/messages

3.11 works find, but I get this with 3.12

It doesn't happen under light load.  I'm running several GPS units over serial and USB to ntpd and gpsd.

Comment 1 Hal Murray 2014-02-13 22:00:05 UTC
Created attachment 862998 [details]
more from /var/log/messages

Comment 2 Hal Murray 2014-02-13 22:04:43 UTC
Sorry for the clutter.  I poked something I didn't intend to.

Typo:  3.11 works fine.

I have many samples in the log files.  tty_flip_buffer_push is in all of them.

Comment 3 Stanislaw Gruszka 2014-02-18 10:09:34 UTC
I reported issue upstream.
https://lkml.org/lkml/2014/2/18/77

For know please use 3.11 kernel.

Comment 4 Stanislaw Gruszka 2014-03-01 17:57:00 UTC
Patch for this bug was merged to tty-next (now law_latency has no effect on tty layer, it can be used as hint to h/w driver though):

https://git.kernel.org/cgit/linux/kernel/git/gregkh/tty.git/commit/?h=tty-next&id=a9c3f68f3cd8d55f809fbdb0c138ed061ea1bd25

Josh, please apply it fix for this bug.

Comment 5 Josh Boyer 2014-03-03 14:21:53 UTC
Fixed in git.  Thanks!

Comment 6 Fedora Update System 2014-03-03 22:56:07 UTC
kernel-3.13.5-202.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.13.5-202.fc20

Comment 7 Fedora Update System 2014-03-03 22:58:46 UTC
kernel-3.13.5-103.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.13.5-103.fc19

Comment 8 Fedora Update System 2014-03-05 05:13:32 UTC
Package kernel-3.13.5-202.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.13.5-202.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3442/kernel-3.13.5-202.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-03-06 08:09:09 UTC
kernel-3.13.5-202.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-03-09 04:37:44 UTC
kernel-3.13.5-103.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Stanislaw Gruszka 2014-03-28 09:39:29 UTC
*** Bug 1081017 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.