Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065069 - RFE: Content specs and Topics should have a search field for the format
Summary: RFE: Content specs and Topics should have a search field for the format
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core
Version: 1.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.4
Assignee: Lee Newson
QA Contact:
URL:
Whiteboard:
: 1062088 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 20:15 UTC by Matthew Casperson
Modified: 2014-08-04 22:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-23 23:43:51 UTC


Attachments (Terms of Use)

Description Matthew Casperson 2014-02-13 20:15:16 UTC
We should be able to search content specs by format i.e. Docbook 4.5 or 5.0.

Comment 1 Lee Newson 2014-02-14 00:14:15 UTC
Moving this to core as it needs to be exposed via the server as well.

Comment 2 Lee Newson 2014-02-14 00:20:52 UTC
Topics should also have this field.

Comment 3 Lee Newson 2014-02-14 03:25:33 UTC
Added in 1.4-SNAPSHOT build 201402141135

The UI doesn't include the "not" fields since at this stage we only have two formats.

The REST query parameters are:

topicFormat
topicNotFormat
contentSpecFormat
contentSpecNotFormat

and the value taken is the constant value for the format:

0 = DocBook 4.5
1 = DocBook 5.0

Comment 4 Lee Newson 2014-02-14 21:36:34 UTC
*** Bug 1062088 has been marked as a duplicate of this bug. ***

Comment 6 Lee Newson 2014-02-17 04:19:59 UTC
Fixed the missing Content Specifications in 1.4-SNAPSHOT build 201402171402

Content Specs without a Format are now returned with the DocBook 4.5 format, since that is the default value when a format isn't specified. 

Note: This version has been deployed to the test/development server.

Comment 7 Matthew Casperson 2014-02-17 05:07:40 UTC
Confirmed.


Note You need to log in before you can comment on or make changes to this bug.