Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1065042 - No interfaces listed for bridge creation
Summary: No interfaces listed for bridge creation
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 18:04 UTC by Bob Doolittle
Modified: 2014-02-14 14:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-14 14:57:44 UTC


Attachments (Terms of Use)
Debug output from virt-manager (deleted)
2014-02-13 18:04 UTC, Bob Doolittle
no flags Details
GUI snapshot showing problem (deleted)
2014-02-13 18:04 UTC, Bob Doolittle
no flags Details
Output of dumpxml for those interfaces listed by iface-list --all (deleted)
2014-02-13 18:18 UTC, Bob Doolittle
no flags Details

Description Bob Doolittle 2014-02-13 18:04:01 UTC
Created attachment 862947 [details]
Debug output from virt-manager

Description of problem:

I was experiencing this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1048351
Assignee claims fix is in git, so I loaded and ran the latest from git://git.fedorahosted.org/virt-manager.git as instructed in Comment #10.

When creating a new bridge, I find I have no interfaces displayed. I have attached:
PNG of GUI dialog
debug output from virt-manager
output of 'virsh iface-dumpxml' for all interfaces listed from 'virsh iface-list --all'


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Try to add a bridge
2.
3.

Actual results:
No interfaces displayed in list, making bridge creation impossible


Expected results:
All interfaces displayed in list


Additional info:

Comment 1 Bob Doolittle 2014-02-13 18:04:51 UTC
Created attachment 862948 [details]
GUI snapshot showing problem

Comment 2 Bob Doolittle 2014-02-13 18:18:28 UTC
Created attachment 862949 [details]
Output of dumpxml for those interfaces listed by iface-list --all

Hardly any interfaces are listed by iface-list --all. I also include "ip addr" output to demonstrate all the missing interfaces.

Comment 3 Cole Robinson 2014-02-14 14:57:44 UTC
Okay, I've worked around this in virt-manager git now, but the root issue seems to be a netcf bug that I've filed over here:

https://bugzilla.redhat.com/show_bug.cgi?id=1065396


Note You need to log in before you can comment on or make changes to this bug.