Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064953 - [RHEVM] [network labels] Failed to configure vm networks on host while changing its cluster.
Summary: [RHEVM] [network labels] Failed to configure vm networks on host while changi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.4.0
Assignee: Moti Asayag
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On: 1065270
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-02-13 15:48 UTC by Martin Pavlik
Modified: 2016-02-10 19:56 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)
screenshot 1 (deleted)
2014-02-13 15:48 UTC, Martin Pavlik
no flags Details
engine_logs (deleted)
2014-02-13 15:49 UTC, Martin Pavlik
no flags Details
host_logs (deleted)
2014-02-13 15:50 UTC, Martin Pavlik
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24518 None None None Never
oVirt gerrit 24571 None None None Never
Red Hat Bugzilla 1065270 None None None Never

Internal Links: 1065270

Description Martin Pavlik 2014-02-13 15:48:50 UTC
Created attachment 862856 [details]
screenshot 1

Description of problem:

host with labeled interface becomes non-operational when moved between clusters with labeled networks, for detailed description see reproduction steps

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.7.beta2.el6 

How reproducible:
100%

Steps to Reproduce:
1. Define Data Center with two clusters: CL1 and CL2
2. Create network NET1 with label lb_1 attached ONLY to cluster CL1
3. Create network NET2 with label lb_1 attached ONLY to cluster CL2
4. add host A to CL1 with interface (other than ovirtmgmt) marked lb_1
5. Move host A from Cluster CL1 to Cluster CL2

Actual results:
host is moved to cluster CL2, but after activation it becomes non operation with complaint that network NET2 is missing on the host (see screenshot), however Setup Networks dialog shows NET2 as attached to the labeled interface

Expected results:
host is moved from CL1 to CL2 and network on interface labeled lb_1 is switched from NET1 to NET2

Additional info:


2014-02-13 15:29:25,004 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-5) [31c51424] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Failed to configure networks on host dell-05 while changing its cluster.

Comment 1 Martin Pavlik 2014-02-13 15:49:37 UTC
Created attachment 862857 [details]
engine_logs

Comment 2 Martin Pavlik 2014-02-13 15:50:08 UTC
Created attachment 862858 [details]
host_logs

Comment 3 Moti Asayag 2014-02-13 23:59:31 UTC
There seems to be two issues with this scenario:

1. The failure to configure a vm network via labels, which seems consistent, specifically since doing the same scenario with vlans works.

2. The setup networks dialog present the network configuration incorrectly. The NET2 network was never configured on the host, therefore it should never present that network as configured on the host.

Please open a dedicated bug for 2.

Comment 4 Martin Pavlik 2014-02-14 08:50:27 UTC
opened bug 1065270 for point 2 from comment 3

Comment 5 Martin Pavlik 2014-03-18 09:02:03 UTC
verified

Red Hat Enterprise Virtualization Manager Version: 3.4.0-0.5.master.el6ev

Comment 6 Itamar Heim 2014-06-12 14:06:53 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.