Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064932 - The code of method _jspService(HttpServletRequest, HttpServletResponse) is exceeding the 65535 bytes limit
Summary: The code of method _jspService(HttpServletRequest, HttpServletResponse) is ex...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web
Version: 6.2.0
Hardware: x86_64
OS: All
unspecified
urgent
Target Milestone: ---
: EAP 6.4.0
Assignee: Rémy Maucherat
QA Contact: Radim Hatlapatka
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 15:12 UTC by kashi
Modified: 2018-12-09 17:31 UTC (History)
8 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-13 15:09:24 UTC
Type: Bug


Attachments (Terms of Use)
JSP which gives error (deleted)
2014-02-13 15:15 UTC, kashi
no flags Details
reproducer (deleted)
2014-08-11 08:47 UTC, Martin Velas
no flags Details

Description kashi 2014-02-13 15:12:59 UTC
Description of problem:

The code of method _jspService(HttpServletRequest, HttpServletResponse) is exceeding the 65535 bytes limit
Version-Release number of selected component (if applicable):
6.2

How reproducible:
If a jsp have lot of applicatoion code beyond certain limit.

Steps to Reproduce:
1.
2.
3.

Actual results:
The code of method _jspService(HttpServletRequest, HttpServletResponse) is exceeding the 65535 bytes limit

Expected results:
JSP should be compiled.


Additional info:

Comment 1 kashi 2014-02-13 15:15:34 UTC
Created attachment 862836 [details]
JSP which gives error

Comment 2 Fernando Nasser 2014-02-14 14:49:23 UTC
Please attach the file test_jsp.java that can be found under the work directory (something like standalone/tmp/worl/<appname>/org/apache/jsp/ ).

Looking at the contents of the _jspService() method in it can give s a clue.

Comment 3 Fernando Nasser 2014-03-04 13:45:16 UTC
A few weeks have passed and the requested information was not provided.  Is this issue obsolete,non-reproducible, no longer an issue for the customer?  Can we close it as NOTABUG?

Comment 4 kashi 2014-06-23 11:07:00 UTC
Hi Fernando,
We have overcome this issue in application by using trimspaces parameter in jsp and resolved this issue.
However this is a nonproducble error. but other App server such as WAS have some parameters to avoid such issues.

Comment 5 Martin Velas 2014-08-11 08:47:51 UTC
Created attachment 925646 [details]
reproducer

simple WAR with JSP exceeding 65535 bytes limit per method.

Comment 6 Martin Velas 2014-08-11 08:50:58 UTC
Using attached reproducer was verified that issue is still valid for EAP 6.3.0.ER10.

You can also verify this issue by deploying this WAR and accessing http://localhost:8080/helloworld/hi.jsp.

Comment 7 Rémy Maucherat 2014-09-02 16:44:45 UTC
Jasper tries its best to optimize and use methods to avoid the issue, but with scriplets and lots of template text anything is possible (since the method is hard to split).

Solutions: using tags and avoiding scriptlets, some amount of dynamic includes, or some config options which affect template text (trimSpaces as mentioned, also mappedfile is reported as helping as well)

If Jasper from JBoss is missing a specific fix or improvement in this area compared to Tomcat, I can look into it, otherwise, no.

Comment 10 Brad Maxwell 2016-07-13 15:09:24 UTC
Closing as per earlier comments


Note You need to log in before you can comment on or make changes to this bug.