Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064876 - [engine-setup][TEXT] 'Install' should be 'Configure' in DWH/Reports questions
Summary: [engine-setup][TEXT] 'Install' should be 'Configure' in DWH/Reports questions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-dwh
Version: 3.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.4.0
Assignee: Yedidyah Bar David
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 13:08 UTC by Jiri Belka
Modified: 2014-07-13 23:20 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:33:16 UTC
oVirt Team: ---


Attachments (Terms of Use)
setup log (deleted)
2014-02-13 13:08 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25533 None None None Never
oVirt gerrit 25534 None None None Never

Description Jiri Belka 2014-02-13 13:08:26 UTC
Created attachment 862781 [details]
setup log

Description of problem:
if engine-setups founds setup files for ovirt-engine-dwh and ovirt-engine-reports on the system (ovirt-engine-dwh-setup/ovirt-engine-reports-setup) it offers a user to configure these services during its own configuration run.

But... As I wrote, it shows question if the user wants to configure them only if the mentioned rpm packages are installed, and this rpm packages get installed as deps of ovirt-engine-dwh and ovirt-engine-reports.

Thus 'Install' in following question is senseless because the services got already installed. (OK, I don't know if engine-setup checks just its plugins for those services or if it checks also their rpms...). Anyway, if the questions are already raised then something at least installed those 'setup' packages.

...
          --== PRODUCT OPTIONS ==--
         
          Install Data Warehouse on this host (Yes, No) [Yes]: 
          Install Reports on this host (Yes, No) [Yes]: 
...


Version-Release number of selected component (if applicable):
ovirt-engine-setup-3.4.0-0.7.beta2.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. install ovirt-engine, ovirt-engine-dwh, ovirt-engine-reports
2. engine-setup
3.

Actual results:
'Install...'

Expected results:
'Configure...' (as the rpms are already installed, thus little confusing.

Additional info:
If engine-setup just checks services' engine-setup plugins only, then I would still go for 'Configure...' and transparently for the user fetch and install ovirt-engine-{dwh,reports} if the rpms are missing.

Comment 1 Itamar Heim 2014-02-16 08:23:58 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 3 Yedidyah Bar David 2014-03-09 09:43:23 UTC
I agree. engine-setup suggests 'Configure' everywhere.

Comment 4 Arthur Berezin 2014-03-09 10:11:47 UTC
(In reply to Yedidyah Bar David from comment #3)
> I agree. engine-setup suggests 'Configure' everywhere.

+1

Comment 5 Barak Dagan 2014-03-27 17:00:41 UTC
Verified on av5:


# rhevm-setup 
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-dwh.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-packaging-rhevm-reports.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20140327185933.log
          Version: otopi-1.2.0 (otopi-1.2.0-1.el6ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          --== PRODUCT OPTIONS ==--
         
          Configure Data Warehouse on this host (Yes, No) [Yes]: 
          Configure Reports on this host (Yes, No) [Yes]:

Comment 6 Sandro Bonazzola 2014-03-31 12:33:16 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.