Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064827 - ssl2jkstrust.py does not get root ca from chain in some cases
Summary: ssl2jkstrust.py does not get root ca from chain in some cases
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.3.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: 3.3.2
Assignee: Alon Bar-Lev
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On: 1058016
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 11:34 UTC by rhev-integ
Modified: 2018-12-05 17:16 UTC (History)
13 users (show)

Fixed In Version: is35 - rhevm-reports-3.3.2-1.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, the rhevm-reports-setup command would sometimes fail to establish PKI trust the machine on which the Red Hat Enterprise Virutalization Manager was installed, causing the command to fail. Now, the method of retrieving the root certificate authority certificate from the SSL session has been revised to support a greater variety of SSL configurations.
Clone Of: 1058016
Environment:
Last Closed: 2014-04-09 18:53:56 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23734 None None None Never
oVirt gerrit 23735 None None None Never
oVirt gerrit 24727 None None None Never
oVirt gerrit 24728 None None None Never
Red Hat Knowledge Base (Solution) 730823 None None None Never
Red Hat Product Errata RHBA-2014:0393 normal SHIPPED_LIVE rhevm-reports 3.3.2 bug fix update 2014-04-09 22:53:18 UTC

Comment 6 Barak Dagan 2014-03-23 10:24:40 UTC
Verified on is35, 3.3.2, on system updated from 3.2:

# rpm -qa | egrep 'rhevm-3|dwh|reports'
rhevm-3.3.2-0.49.el6ev.noarch
rhevm-dwh-3.3.2-1.el6ev.noarch
jasperreports-server-pro-5.5.0-6.el6ev.noarch
rhevm-reports-3.3.2-3.el6ev.noarch

2014-03-20 12:38:16::DEBUG::rhevm-reports-setup::912::root:: downloading certificates https://MyHost:443
2014-03-20 12:38:16::DEBUG::common_utils::1024::root:: Executing command --> '/usr/share/ovirt-engine-reports/ssl2jkstrust.py --host=fire32-rep.scl.lab.tlv.redhat.com --port=443 --keystore=/etc/ovirt-engine/ovirt-engine-reports/trust.jks --storepass=mypass' in working directory '/etc/yum.repos.d'
2014-03-20 12:38:17::DEBUG::common_utils::1079::root:: output =
2014-03-20 12:38:17::DEBUG::common_utils::1080::root:: stderr = Certificate was added to keystore

Comment 7 Zac Dover 2014-04-03 03:10:22 UTC
This bug is currently attached to errata RHBA-2014:17207 If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.

* Consequence: What happens when the bug presents.

* Fix: What was done to fix the bug.

* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks in advance.

Comment 9 errata-xmlrpc 2014-04-09 18:53:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0393.html


Note You need to log in before you can comment on or make changes to this bug.