Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064761 - qemu-kvm should give a reasonable cause when boot guest with libgfapi and x-data-plane=on storage
Summary: qemu-kvm should give a reasonable cause when boot guest with libgfapi and x-d...
Keywords:
Status: CLOSED DUPLICATE of bug 1031965
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Stefan Hajnoczi
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 09:24 UTC by Jun Li
Modified: 2014-02-13 23:34 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-13 23:34:31 UTC


Attachments (Terms of Use)

Description Jun Li 2014-02-13 09:24:23 UTC
Description of problem:
As currently, dataplane only supports local files using Linux AIO.
qemu-kvm does not give a reasonable cause when boot guest with libgfapi and x-data-plane=on storage.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-47.el7.x86_64
3.10.0-86.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot guest with cli:
# /usr/libexec/qemu-kvm -M pc -m 4G -smp 4 -boot menu=on,reboot-timeout=-1,strict=on -monitor stdio -spice port=5933,disable-ticketing -vga qxl \
-drive file=gluster://10.66.6.82:24007/gv0/win2003sp2-64.raw,if=none,format=raw,id=disk,cache=none,rerror=stop,werror=stop,serial="QEMU-DISK1",aio=native \
-device virtio-blk-pci,drive=disk,id=sys_disk,scsi=off,x-data-plane=on,serial=xxxx,config-wce=off  \
-netdev tap,id=tap1,vhost=on,queues=4,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown -device  virtio-net-pci,mq=on,vectors=17,netdev=tap1,id=net1,mac=24:be:05:0c:22:22 \
-drive file=/home/juli/virtio-win-prewhql-0.1-74.iso,if=none,media=cdrom,id=cdrom \
-device ide-cd,bus=ide.0,unit=0,drive=cdrom,id=sys-cdrom
2.
3.

Actual results:
QEMU 1.5.3 monitor - type 'help' for more information
(qemu) qemu-kvm: -device virtio-blk-pci,drive=disk,id=sys_disk,scsi=off,x-data-plane=on,serial=xxxx,config-wce=off: drive is incompatible with x-data-plane, use format=raw,cache=none,aio=native
qemu-kvm: -device virtio-blk-pci,drive=disk,id=sys_disk,scsi=off,x-data-plane=on,serial=xxxx,config-wce=off: Device initialization failed.
qemu-kvm: -device virtio-blk-pci,drive=disk,id=sys_disk,scsi=off,x-data-plane=on,serial=xxxx,config-wce=off: Device initialization failed.
qemu-kvm: -device virtio-blk-pci,drive=disk,id=sys_disk,scsi=off,x-data-plane=on,serial=xxxx,config-wce=off: Device 'virtio-blk-pci' could not be initialized

Expected results:
maybe give some warning: dataplane currently only supports local files using Linux AIO.

Additional info:

Comment 2 Sibiao Luo 2014-02-13 09:58:44 UTC

*** This bug has been marked as a duplicate of bug 1049773 ***

Comment 5 Paolo Bonzini 2014-02-13 23:34:31 UTC

*** This bug has been marked as a duplicate of bug 1031965 ***


Note You need to log in before you can comment on or make changes to this bug.