Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064693 - Injections to revision history topic result in validation error
Summary: Injections to revision history topic result in validation error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core
Version: 1.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.4
Assignee: Lee Newson
QA Contact:
URL:
Whiteboard:
: 1065157 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 05:57 UTC by Matthew Casperson
Modified: 2014-08-04 22:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-23 23:43:51 UTC


Attachments (Terms of Use)

Description Matthew Casperson 2014-02-13 05:57:03 UTC
See spec 22688 on the dev server. Topic 30505 has an injection to topic 28948, which is the revision history topic. This generates an error:

ERROR: Topic has referenced Topic/Level(s) 28948 in a custom injection point that was not included this book.

Comment 3 Lee Newson 2014-02-13 07:22:14 UTC
Fixed in 1.4-SNAPSHOT build 201402131720

Fixed the injection resolution to look up Meta Data topics as well. Also configured the builder to add ids for all current metadata topic types.

Comment 6 Matthew Casperson 2014-02-13 20:14:04 UTC
Confirmed the fix.

Comment 7 Lee Newson 2014-02-14 04:32:04 UTC
*** Bug 1065157 has been marked as a duplicate of this bug. ***

Comment 8 Lee Newson 2014-02-14 04:32:48 UTC
Moving back to assigned as the injection doesn't work for invalid revision histories. See BZ#1065157

Comment 9 Lee Newson 2014-02-14 04:48:41 UTC
Moving back to VERIFIED as we cannot reproduce it, so it's possible an older temporary file was used.

Comment 10 Lee Newson 2014-02-14 06:59:46 UTC
You can replicate the issue above by failing the Fixed URL pass, so moving this back to ASSIGNED.

Comment 11 Lee Newson 2014-02-14 07:02:55 UTC
Fixed in 1.4-SNAPSHOT build 201402141700

If a networking error occurred during any stage of the Fixed URL pass then the entire process would fail and wouldn't be attempted again. This also meant that any static Fixed URLs (ie Revision History, Author Group, etc...) weren't being set.

There was also the issue of the Revision History always attempting to use the static human readable URL, when it should have been using the same mechanism as the rest of the topics.

Comment 13 Matthew Casperson 2014-02-17 03:35:26 UTC
I had a build fail with the issue described in https://bugzilla.redhat.com/show_bug.cgi?id=1065586, but the xrefs all still resolved, even to the revision history.


Note You need to log in before you can comment on or make changes to this bug.