Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064689 - 0.34 version request
Summary: 0.34 version request
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Module-Build-Tiny
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 05:23 UTC by Christopher Meng
Modified: 2014-02-27 14:44 UTC (History)
3 users (show)

Fixed In Version: perl-Module-Build-Tiny-0.035-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-13 09:51:17 UTC


Attachments (Terms of Use)

Description Christopher Meng 2014-02-13 05:23:57 UTC
Hi,

My module WebService::Linode requires Module::Build::Tiny 0.34 at least, not sure if you can update.

Thanks.

Comment 1 Paul Howarth 2014-02-13 09:51:17 UTC
Can't do it I'm afraid. Versions beyond 0.028 that's in EPEL-7 require TAP::Harness 3.29 or later (for TAP::Harness::Env), and RHEL-7 ships with TAP::Harness 3.28. Red Hat are unlikely to respond favourably to a request to update that for much the same reasons that it wasn't updated in Fedora 20 (see Bug #1018157).

Fortunately, the requirement for the latest version of Module::Build::Tiny is not usually a real one. The dependency is almost always a result of upstream's use of  Dist::Zilla::Plugin::ModuleBuildTiny, which adds a dependency on the version of Module::Build::Tiny on the upstream author's system at the time of doing the release. It's usually the case that patching the version requirement down to 0.028 will result in a working build.

Comment 2 Paul Howarth 2014-02-19 16:58:40 UTC
Following a discussion with upstream, I have found a way to update Module::Build::Tiny in F-20 and EPEL-7. First, though, somebody needs to review a perl-TAP-Harness-Env package (Bug #1067098).

Comment 3 Paul Howarth 2014-02-27 14:44:17 UTC
Module::Build::Tiny version 0.035 (current upstream release) is now available for EPEL-7.


Note You need to log in before you can comment on or make changes to this bug.