Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064654 - rsync fails to hardlink backup to previous day's backup after upgrade to FC20
Summary: rsync fails to hardlink backup to previous day's backup after upgrade to FC20
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rsync
Version: 20
Hardware: i686
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Michal Luscon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 03:24 UTC by Walter Neumann
Modified: 2014-05-07 16:36 UTC (History)
4 users (show)

Fixed In Version: rsync-3.1.0-3.fc20.i686
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-07 16:36:55 UTC


Attachments (Terms of Use)

Description Walter Neumann 2014-02-13 03:24:15 UTC
Description of problem: rsync fails to hard link. 

The actual command I used to test this bug is essentially:

rsync -azhHXE -e ssh --rsync-path="rsync --fake-super --link-dest=/backup/test"  test backup@mybackupserver.bla:/backup/testt

Version-Release number of selected component (if applicable): 
rsync-3.1.0-2.fc20.i686


How reproducible:  Always

Steps to Reproduce:

1. Set up appropriate directories to run the test and fill directory "test" on the local machine with some junk.

2. Run the above command in the directory containing the directory "test"

3. On server "mybackupserver.bla" move the file /backup/testt to /backup/test  and then repeat step 2 (so /backup now contains directories testt and test).

Actual results:

It should have hardlinked all the files in the directory "testt" to those in directory "test" but it hasn't.

Expected results:

Files get linked.

Additional info:

I have had a daily backup from a local machine to a remote machine using essentially the above command running without problems for years, but then in the last few weeks it stopped hardlinking to previous backups. I only noticed when the backup drive suddenly filled up.  Nothing has changed on the local machine. The remote machine was upgraded from FC19 to FC20 using fedup about 3 weeks ago.

Replacing rsync on the remote machine by an earlier version fixed the problem, both for the toy test above and for my actual backups.  (The earlier version I used is about 4 years old)

My guess is that this bug appeared in the upgrade of the remote machine from FC19 to FC20, but it could have been soon after (I replaced the backup drive with a larger drive before I realized it was a software problem, so it is hard to pinpoint exactly when the bug arrived).

Comment 1 Michal Luscon 2014-05-07 15:12:29 UTC
Unfortunately, I can't reproduce this bug. My steps:

local:
$mkdir test
$touch test/foo
$rsync -azhHXE -e ssh --fake-super --rsync-path="rsync --link-dest=/backup/test"  test root@192.168.122.70:/backup/testt 

remote:
$mv /backup/testt /backup/test

local:
$rsync -azhHXE -e ssh --fake-super --rsync-path="rsync --link-dest=/backup/test"  test root@192.168.122.70:/backup/testt

Could you please try this simple scenario?

Comment 2 Walter Neumann 2014-05-07 16:36:55 UTC
I no longer have rsync-3.1.0-2.fc20.i686 to test. I can't reproduce the bug with rsync-3.1.0-3.fc20.i686.  So it can be marked as "fixed". Thanks for testing.

I'm not convinced that the issue was in rsync, despite an older rsync working OK. I'm more inclined to suspect an interaction with some other program or with the kernel, and there have been lots of updates since I filed the bug.


Note You need to log in before you can comment on or make changes to this bug.