Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064574 - [RFE] Add ISO+export options to "add more storage" in data center guide-me
Summary: [RFE] Add ISO+export options to "add more storage" in data center guide-me
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ---
: ---
Assignee: Allon Mureinik
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks: 1065731
TreeView+ depends on / blocked
 
Reported: 2014-02-12 21:29 UTC by Matt Reid
Modified: 2017-03-13 11:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1065731 (view as bug list)
Environment:
Last Closed: 2017-03-13 11:00:11 UTC
oVirt Team: Storage
ylavi: ovirt-future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
Only Data / NFS offered as choice from dialog (deleted)
2014-02-12 21:30 UTC, Matt Reid
no flags Details

Description Matt Reid 2014-02-12 21:29:00 UTC
Description of problem:
Following the guide https://access.redhat.com/site/articles/703153 to set up storage, it tells you to:

Add ISO Library: Select Add More Storage (or Attach ISO Library if the ISO domain was created during setup). From the New Storage pop-up that appears, type a name for the new ISO storage (such as ISO_DOMAIN), make sure ISO/NFS is the storage type, for Use Host have your RHEV-H appear, and set the export path to the NFS share you created earlier for the ISO domain. For example, rhevm.example.com:/var/lib/exports/iso. Then click OK. (Or, just select the ISO domain you created during setup and select OK.)

In my experience, at least using RHEV 3.2, the New Storage dialog that pops up when you click on Add More Storage from the Guide Me dialog only lets you choose "Data / NFS" and you can't set it to be any other type.

Either the doc may need an update to have them create the storage outside of the Guide Me dialog, or ideally, it seems like RHEV should let you change the type there. The button doesn't say Add More Data Storage, it's just Storage, I would expect to be able to modify the type and not have to back out of the Guide Me dialog, go over to the Storage tab, and pop open the same new storage dialog there.

Version-Release number of selected component (if applicable):
3.2

Steps to Reproduce:
1. Log into admin portal
2. Go to Data Centers tab, click on a data center
3. Click on Guide Me
4. Click Add More Storage
5. Click on the Domain Function / Storage Type dropdown

Actual results:
Only Data / NFS offered as a selection

Expected results:
Be able to select the other types, like you can when you access this New Storage dialog from the Storage tab

Additional info:

Comment 1 Matt Reid 2014-02-12 21:30:20 UTC
Created attachment 862537 [details]
Only Data / NFS offered as choice from dialog

Comment 2 Vered Volansky 2014-02-16 12:39:28 UTC
In 3.2 there are specific storage types for data center, in this case (screenshot) NFS. In this case it's acceptable to only add an nfs storage domain.
Opening another bug on docs as a clone.

Comment 3 Jodi Biddle 2014-02-16 22:19:41 UTC
Please note that KCS articles are not part of the official product documentation suite, and are subject to frequent change. Chris Negus is most likely the author of this document. 

Chris, can you please confirm this is your document so I can change the assignee to you?

Comment 4 Allon Mureinik 2014-02-18 07:22:56 UTC
(In reply to Jodi Biddle from comment #3)
> Please note that KCS articles are not part of the official product
> documentation suite, and are subject to frequent change. Chris Negus is most
> likely the author of this document. 
> 
> Chris, can you please confirm this is your document so I can change the
> assignee to you?

There are two issues here:

1. A lacking feature in the product ("future feature", "improvement", call it what you will) - the Guide Me dialog should allow adding ISO and Export domains.

2. The fact that the KCS article conveys wrong information in light of the /current/ product's features.

Both issues need to be solved at some point of time or the other (based on the relevant assignee's prioritization), and both need to be tracked.
So far, we've been using this BZ to track issue (1). 
Jodi/Chris - unfortunately, I'm not really familiar with the work-process for content engineering. How should we track issue (2) in a way it won't interfere with tracking issue (1)? Add a doc-text-required flag? Open a new bug? Something else?


Thanks in advance,
Allon

Comment 5 Chris Negus 2014-02-18 11:59:00 UTC
(In reply to Jodi Biddle from comment #3)
> Please note that KCS articles are not part of the official product
> documentation suite, and are subject to frequent change. Chris Negus is most
> likely the author of this document. 
> 
> Chris, can you please confirm this is your document so I can change the
> assignee to you?

Yes. The article https://access.redhat.com/site/articles/703153 is my document. I'll make the fix and respond back here when it is done.

Comment 6 Chris Negus 2014-03-04 20:22:40 UTC
I fixed the article: https://access.redhat.com/site/articles/703153. It now notes that only DATA/NFS should be available as the storage type, since that was the storage type assigned to the datacenter.

Comment 7 Itamar Heim 2014-07-15 12:47:38 UTC
I'm not sure if we should fix this, as we are trying to make iso/export being "just paths", rather than storage domains.

Comment 8 Yaniv Kaul 2017-03-13 11:00:11 UTC
Closing, as we hope to deprecate both domain types in the future.


Note You need to log in before you can comment on or make changes to this bug.