Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064573 - left side menu not structured when on system details page
Summary: left side menu not structured when on system details page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space21
TreeView+ depends on / blocked
 
Reported: 2014-02-12 21:23 UTC by Jan Hutař
Modified: 2014-03-04 13:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-04 13:07:15 UTC


Attachments (Terms of Use)
differences in menu (deleted)
2014-02-12 21:45 UTC, Jan Hutař
no flags Details

Description Jan Hutař 2014-02-12 21:23:25 UTC
Description of problem:
Left side menu is not structured when you are on system details page.


Version-Release number of selected component (if applicable):
spacewalk-java-2.1.148-1.el6.noarch


How reproducible:
always on one system where I have checked


Steps to Reproduce:
1. On webUI go to Systems -> Systems and notice menu on the left
   https://<fqdn>/rhn/systems/SystemList.do
2. Select some system and go to its details page and notice menu on the left now
   https://<fqdn>/rhn/systems/details/Overview.do?sid=1000010384


Actual results:
In first step left side menu has two levels of indentation, in second step the menu do not have second indentation level, all items are indented equally. Check screenshot.


Expected results:
Menu on the left should look similar for both cases.

Comment 1 Jan Hutař 2014-02-12 21:38:18 UTC
Sorry, menu on system details page is OK. Menu on system details -> Events is the one where I can see the problem. So step 2 should be:

2. Select some system and go to its details page -> Events and notice menu
   on the left now:
   https://<fqdn>/network/systems/details/history/pending.pxt?sid=1000010384

Comment 2 Jan Hutař 2014-02-12 21:45:03 UTC
Created attachment 862539 [details]
differences in menu

Comment 3 Tomáš Kašpárek 2014-02-13 08:26:06 UTC
looks like perl vs. java issue (left side menu have probably different classes in perl and java) - taking

Comment 4 Tomáš Kašpárek 2014-02-17 15:38:31 UTC
fixed in spacewalk.git: 3c15a2224365758e215497100ed54ae7eb4d1944
f3dbd0d5cbe1d8939cb7a2ee871383de94238f81

perl generated html valid side navigation while did not, I've fixed java code to generate html valid navogation and css to respect html valid navigation

pasting there from commit message of 3c15a2224365758e215497100ed54ae7eb4d1944

1064573 - make sidenav html valid
    
constructs like:
<ul>
  <li>..</li>
  <ul>
    <li>..</li>
  </ul>
</ul>
    
are not html valid, replacing them with valid ones like:
<ul>
  <li>..</li>
  <li><ul>
    <li>..</li>
  </ul></li>
</ul>
    
nested <ul>s should be inside <li>

Comment 5 Matej Kollar 2014-03-04 13:07:15 UTC
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21

Comment 6 Matej Kollar 2014-03-04 13:08:45 UTC
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21


Note You need to log in before you can comment on or make changes to this bug.