Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064483 - Selected values from enumeration are not persisted upon the page refresh in Guided Rule Editor
Summary: Selected values from enumeration are not persisted upon the page refresh in G...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ER2
: 6.0.1
Assignee: manstis
QA Contact: Jiri Locker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 16:57 UTC by Anton Giertli
Modified: 2018-12-04 17:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 19:57:18 UTC
Type: Bug


Attachments (Terms of Use)
screenshots from the guided editor (deleted)
2014-02-12 17:06 UTC, Anton Giertli
no flags Details

Description Anton Giertli 2014-02-12 16:57:56 UTC
Description of problem:

When you create a rule using Guided Editor, and you create a condition on an fact attributes which is associated with enumeration, selected values from the enumeration are not shown after page refresh though the original values are still visible in the 'source' tab.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create fact TestFact
2. Create attribute testAttr
3. Create enumeration , for example:
 
Fact    Field      Context
'TestFact.testAttr' : ["20","30","40","50","60","70"]

4. Now create a guided rule, with the condition on the TestFact, then add restriction on the testAttr field and choose "is contained in the". 
5. Select 'literal value' and the list of the values from the enum is now displayed. Select values "20","30"
6. You can check under the 'source' tab that the values are really selected.
7. Save the rule
8. Refresh the page, and navigate to the same rule again. The values are not selected from the list. However, under the 'source' tab the original values are still visible.

Actual results:
Values previously selected in the list are not visible after page refresh in the UI, only in the generated code.

Expected results:
Selected values should 'survive' the page refresh in both - generated code && UI.

Additional info:

Comment 1 Anton Giertli 2014-02-12 17:06:23 UTC
Created attachment 862456 [details]
screenshots from the guided editor

I have added some screenshots for further demonstration of the issue. I have had the feeling that the description is far too verbose and complex..

Comment 4 manstis 2014-02-13 15:44:27 UTC
It looks like this BZ has been reported with an old version of BPMS/BRMS (as the icons in the Project Explorer are out of date). I tried to replicate this issue with the latest build but was unable.


Note You need to log in before you can comment on or make changes to this bug.