Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064438 - 3.4 cluster version requires a newer version of libvirt which isn't available for ppc64
Summary: 3.4 cluster version requires a newer version of libvirt which isn't available...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.4
Hardware: ppc64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact: Aharon Canan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 15:57 UTC by Vitor de Lima
Modified: 2014-02-18 19:43 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-12 17:52:00 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Vitor de Lima 2014-02-12 15:57:28 UTC
Description of problem:
If VDSM 4.14 is used together with the libvirt that is shipped with Fedora 19, the 3.4 cluster version is reported as unsupported by the host. This can be fixed in x86-64 hosts by installing the libvirt available in the virt-preview repository, but this is not available for ppc64. The only way to get a working setup is to manually create RPMS for libvirt from the source code.

Version-Release number of selected component (if applicable):
Fedora 19
libvirt 1.0.5.8-1.fc19

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 19 and VDSM in a ppc64 host
2. Try to add it as a host into a 3.4 cluster using the oVirt engine

Actual results:
The host is marked as non-operational because the cluster level is not supported by VDSM.

Expected results:
The host is added into the cluster.

Additional info:

Comment 1 Dan Kenigsberg 2014-02-12 17:52:00 UTC
Since there's no ppc64 under http://fedorapeople.org/groups/virt/virt-preview/fedora-19/ there is nothing much you can do: either build libvirt yourself, or move to Fedora 20.


Note You need to log in before you can comment on or make changes to this bug.