Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064405 - Missing dependencies of org.picketlink.common module
Summary: Missing dependencies of org.picketlink.common module
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: PicketLink
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR2
: EAP 6.3.0
Assignee: Peter Skopek
QA Contact: Hynek Mlnarik
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 14:32 UTC by Hynek Mlnarik
Modified: 2015-09-01 03:34 UTC (History)
4 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-28 15:25:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Hynek Mlnarik 2014-02-12 14:32:57 UTC
The org.picketlink.common in EAP 6.3.0.DR0 is missing dependencies to WS and JAXB which leads to the following failures in PL testsuite:

[org.apache.cxf.phase.PhaseInterceptorChain] (http-localhost/127.0.0.1:8080-1) Interceptor for {urn:picketlink:identity-federation:pdp}SOAPSAMLXACMLPDP#{http://cxf.apache.org/jaxws/provider}invoke has thrown exception
[...]
Caused by: java.lang.NoClassDefFoundError: javax/xml/bind/util/JAXBSource
[...]
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.util.JAXBSource from [Module "org.picketlink.common:main" from local module loader @6fbc18ca (finder: local module finder @25ffaf15 (roots: [...]/jboss-eap-6.3/modules,[...]/jboss-eap-6.3/modules/system/layers/base))]


and


[org.apache.cxf.phase.PhaseInterceptorChain] (http-localhost/127.0.0.1:8080-1) Interceptor for {urn:picketlink:identity-federation:sts}PicketLinkSTS#{http://cxf.apache.org/jaxws/provider}invoke has thrown exception
[...]
Caused by: java.lang.NoClassDefFoundError: javax/xml/ws/WebServiceException
[...]
Caused by: java.lang.ClassNotFoundException: javax.xml.ws.WebServiceException from [Module "org.picketlink.common:main" from local module loader @6fbc18ca (finder: local module finder @25ffaf15 (roots: [...]/jboss-eap-6.3/modules,[...]/jboss-eap-6.3/modules/system/layers/base))]

Comment 1 Peter Skopek 2014-03-04 19:12:31 UTC
Pull Request: https://github.com/jbossas/jboss-eap/pull/1004

Comment 2 Peter Skopek 2014-03-04 19:13:59 UTC
Upstream JIRA: https://issues.jboss.org/browse/WFLY-3065

Comment 3 Hynek Mlnarik 2014-03-10 14:37:08 UTC
Verified in 6.3.0.DR2


Note You need to log in before you can comment on or make changes to this bug.