Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064391 - Server-wide configuration of picketlink 2.5
Summary: Server-wide configuration of picketlink 2.5
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: PicketLink
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Anil Saldhana
QA Contact: Hynek Mlnarik
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 14:14 UTC by Hynek Mlnarik
Modified: 2015-09-01 03:34 UTC (History)
2 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 12:38:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Hynek Mlnarik 2014-02-12 14:14:33 UTC
An attempt to configure picketlink in EAP 6.3.0.DR0 in standalone.xml fails.

According to Note in documentation, https://docs.jboss.org/picketlink/2/latest/reference/html_single/#d5e2138 (Chapter 11.2. Installation and Configuration), there should be no additional setup needed. Tried to add the following line where picketlink configuration belongs into <profile> in standalone.xml:

   <subsystem xmlns="urn:jboss:domain:picketlink:1.0" />

However, the server fails to start with the following message:

ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.server.ServerService.boot(ServerService.java:324) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:253) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]
Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[81,2]
Message: Unexpected element '{urn:jboss:domain:picketlink:1.0}subsystem'
        at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:108) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
        at org.jboss.staxmapper.XMLExtendedStreamReaderImpl.handleAny(XMLExtendedStreamReaderImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
        at org.jboss.as.server.parsing.StandaloneXml.parseServerProfile(StandaloneXml.java:1024) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_4(StandaloneXml.java:458) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:145) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:107) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
        at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        ... 3 more



Further adding <extension module="org.picketlink.as.extension" /> into <extensions> does not help, either. Server fails to start with message:

(Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration                 
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.server.ServerService.boot(ServerService.java:324) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:253) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]
Caused by: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module org.picketlink.as.extension
        at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(ExtensionXml.java:154) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_4(StandaloneXml.java:434) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:145) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:107) [jboss-as-server-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
        at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        ... 3 more
Caused by: java.util.concurrent.ExecutionException: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module
        at java.util.concurrent.FutureTask.report(FutureTask.java:122) [rt.jar:1.7.0_51]
        at java.util.concurrent.FutureTask.get(FutureTask.java:188) [rt.jar:1.7.0_51]
        at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(ExtensionXml.java:146) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        ... 9 more
Caused by: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module
        at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java:195) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.controller.parsing.ExtensionXml.access$000(ExtensionXml.java:68) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:126) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:123) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_51]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]
        at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.1.Final-redhat-1.jar:2.1.1.Final-redhat-1]
Caused by: org.jboss.modules.ModuleNotFoundException: org.picketlink.as.extension:main
        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:240) [jboss-modules.jar:1.3.0.Final-redhat-2]
        at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java:177) [jboss-as-controller-7.4.0.Final-redhat-0.jar:7.4.0.Final-redhat-0]
        ... 8 more


Note You need to log in before you can comment on or make changes to this bug.