Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064327 - [RFE] foreman should support the configuration on NICs, and VLAN and the combinations
Summary: [RFE] foreman should support the configuration on NICs, and VLAN and the comb...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: z1
: Installer
Assignee: RHOS Maint
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks: 1040649 1139328
TreeView+ depends on / blocked
 
Reported: 2014-02-12 12:37 UTC by Steve Reichard
Modified: 2014-10-01 13:24 UTC (History)
10 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.3.2-1.el6ost
Doc Type: Enhancement
Doc Text:
A feature has been added to the RHEL OpenStack Platform installer which allows you to configure subnets and network interfaces in a deployment. This was required because OpenStack can have its networks configured in a variety of ways. As a result, you can now define various subnets for some pre-defined traffic types. You can then assign each interface on a host to a subnet.
Clone Of:
: 1139328 (view as bug list)
Environment:
Last Closed: 2014-10-01 13:24:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Steve Reichard 2014-02-12 12:37:30 UTC
Description of problem:

IfI am currently deploying RHEL OSP using the foreman automation utility, I first must manually configure any NICs and BONDs including associating them with any VLANs before apply a RHEL OSP host group.  

I believe (also heard from Dell Partner) that it may be expected that this configuration should be handled by the automation tool


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Crag Wolfe 2014-02-12 23:51:11 UTC
If we want bonded NIC's, it feels a configuration that should take place in provisioning mode, in a provisioning template.  Does that align with expectations?

Comment 3 Steve Reichard 2014-02-13 14:06:12 UTC
Wouldn't the proposal limit the use of bonds to only when the Operating Systems is provisioned?  That would mean a user who wants to install a HA RHOS environment, must use Foreman bare metal provioning, and would require them to re-install the system.

Say someone has a different baremetal provisioning system (cobbler) we would say our autoamted RHOS HA installed requires you to manually configure you bonds?

Just to clarify, you request is just for bonds.  Do you agree tht configuring NICs with/without VLANs is something that is not a baremetal time operation?

Comment 4 Crag Wolfe 2014-02-14 19:51:25 UTC
>Wouldn't the proposal limit the use of bonds to only when the Operating Systems >is provisioned?  That would mean a user who wants to install a HA RHOS >environment, must use Foreman bare metal provioning, and would require them to >re-install the system.

Well, I guess it would require they have some way of configuring bonded nic's.  Right now in our host groups general, we assume that IP addresses are already up on interfaces already decided by the user.

I have to admit I'm getting lost in the VLAN wrinkle.  But, I think one alternative would be to take MAC addresses as parameters in our host groups instead of nic's and IP's.

Comment 6 Steve Reichard 2014-06-02 14:15:33 UTC
Unclear at this time.

Dell has started to test and initially saw issues were the name of vlan devices are getting mangled. (eth0.100 is being translated to eth0_100) whic failes to come up.

Believe they have BZ'd this. I beleive this will be an issue with staypuft.


If they have success using foreman, I will update.

Comment 8 Mike Burns 2014-09-08 16:50:16 UTC
Bonding moved to bug 1139328

Comment 11 Ofer Blaut 2014-09-29 14:58:29 UTC
User can configure different subnet to different NIC, per host including VLAN per subnet 

rhel-osp-installer-0.3.6-1.el6ost.noarch
ruby193-rubygem-staypuft-0.3.9-1.el6ost.noarch

Comment 13 errata-xmlrpc 2014-10-01 13:24:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.