Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064315 - Dist-geo-rep : If one of the slave node goes down, the worker connected to doesn't sync anything until that node comes back.
Summary: Dist-geo-rep : If one of the slave node goes down, the worker connected to do...
Keywords:
Status: CLOSED DUPLICATE of bug 1126798
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: 2.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Aravinda VK
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 12:10 UTC by Vijaykumar Koppad
Modified: 2014-12-04 09:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-04 09:21:27 UTC


Attachments (Terms of Use)

Description Vijaykumar Koppad 2014-02-12 12:10:34 UTC
Description of problem: If one of the slave node goes down, the brick connected to doesn't sync anything until that node comes back. There should be a way where, the worker which is connected to unreachable node, should try to connect to a different node and continue syncing. 


Version-Release number of selected component (if applicable): glusterfs-3.4.0.59rhs-1

How reproducible: Happens everytime 


Steps to Reproduce:
1. create and start a geo-rep relationship between master(6x2 with 4 nodes) and slave( 6x2 with 4 nodes)  
2. bring down one of the slave node. 
3. wait for some time and check the status. 


Actual results:  If one of the slave node goes down, the worker connected to doesn't sync anything until that node comes back. 


Expected results:There should be a way where, the worker which is connected to unreachable node, should try to connect to a different node and continue syncing. 


Additional info:

Comment 3 Aravinda VK 2014-12-04 09:21:27 UTC

*** This bug has been marked as a duplicate of bug 1126798 ***


Note You need to log in before you can comment on or make changes to this bug.