Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064295 - [RHSC] - Remove brick icon does not come in the volume activities column while performing remove-brick
Summary: [RHSC] - Remove brick icon does not come in the volume activities column whil...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: RHGS 3.0.0
Assignee: Sahina Bose
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1035040
TreeView+ depends on / blocked
 
Reported: 2014-02-12 11:21 UTC by RamaKasturi
Modified: 2015-05-13 16:53 UTC (History)
12 users (show)

Fixed In Version: rhsc-3.0.0-0.5.master.el6_5
Doc Type: Bug Fix
Doc Text:
Previously while performing a remove brick operation, clicking the "Remove" button before the pop-up closed on Remove Brick window led to a remove brick operation failure, and the remove brick icon was not displayed in the Activities column. With this fix, the Remove-brick icon appears in the volume activities column, the tasks in the task pane are updated as expected, and an appropriate message is displayed if the remove brick icon is clicked when a task is already in progress.
Clone Of:
Environment:
Last Closed: 2014-09-22 19:07:30 UTC


Attachments (Terms of Use)
Attaching the same. (deleted)
2014-02-12 11:21 UTC, RamaKasturi
no flags Details
Sql script to clean failed gluster jobs (deleted)
2014-02-18 08:31 UTC, Sahina Bose
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1277 normal SHIPPED_LIVE Red Hat Storage Console 3.0 enhancement and bug fix update 2014-09-22 23:06:30 UTC
oVirt gerrit 24364 master MERGED engine: Fixed view to return correct task Never

Description RamaKasturi 2014-02-12 11:21:37 UTC
Created attachment 862216 [details]
Attaching the same.

Description of problem:
Remove icon does not come in the volume activites column while performing remove brick.

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.36.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a distribute volume and start remove -brick.
2. Now remove-brick popup gets opened , click on ok button.
3. Now close the popup dialog.
4. Remove button gets enabled .
5. Click on Remove again.

Actual results:
Remove-brick icon does not come in the volume activities column and the task in the task pane remains in "pending commit" state, performing remove-brick or rebalance says " A task is already in progress." See the attached screenshot.

Expected results:
1) Remove-brick icon should appear in the volume activities column.
2) Once remove-brick is started , remove button should not get enabled.
3) Task in the task pane should be updated properly.

Additional info:

Comment 2 RamaKasturi 2014-02-12 12:10:58 UTC
Attaching the sosreports for the same.

http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1064295/

Comment 3 Dusmant 2014-02-14 06:49:19 UTC
As discussed over e-mail, I am marking for Denali. Sahina already has a fix for this.

Comment 4 Dusmant 2014-02-14 06:52:38 UTC
This bug will be documented as a known issue in Corbett release.

Comment 5 Shalaka 2014-02-18 06:57:32 UTC
Please review the edited doc text and sign off.

Comment 6 Sahina Bose 2014-02-18 08:31:50 UTC
Created attachment 864412 [details]
Sql script to clean failed gluster jobs

The clean_failed_gluster_jobs.sql will remove failed job entries which have no associated gluster task ids

Comment 7 Sahina Bose 2014-02-18 08:35:30 UTC
Add to workaround to run attached sql file like this:

$ psql --username <dbusername> -d <enginedatabase> -a -f clean_failed_gluster_jobs.sql

example:

$ psql --username postgres -d engine -a -f clean_failed_gluster_jobs.sql

Comment 8 Shalaka 2014-02-19 09:03:07 UTC
Updated the doc text as suggested in comment 7.

Comment 9 RamaKasturi 2014-05-24 10:08:18 UTC
Verified as fixed in rhsc-3.0.0-0.5.master.el6_5.noarch.

With this fix:

 1) Remove-brick icon should appear in the volume activities column.
 
 2) Tasks in the task pane gets updated properly.

 3) Remove brick icon is still enabled, but clicking on that says "Error while executing action: Cannot start remove Gluster Brick(s). A task is in progress on the volume vol_dis in cluster Import-cluster."

Comment 10 Pavithra 2014-07-09 06:53:51 UTC
Hi Sahina,

Please review the edited doc text for technical accuracy and sign off.

Comment 11 Sahina Bose 2014-09-17 05:26:50 UTC
Doc text looks fine

Comment 13 errata-xmlrpc 2014-09-22 19:07:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1277.html


Note You need to log in before you can comment on or make changes to this bug.